Search found 17 matches

by timohan
08 Aug 2017 08:35
Forum: RaZberry
Topic: Z-Wave v2.3.5 is out
Replies: 18
Views: 656

Re: Z-Wave v2.3.5 is out

2.3.5 is caused linux system crash in one week using due stress test. -> I guess I am going back to homegenie, and I hope z-way-server will be fixed someday. -> I think the reason is heavy I/O (json/log) usage or just heavy CPU usage (or combination). According to top, sometimes CPU usage z-way-serv...
by timohan
04 Aug 2017 19:02
Forum: RaZberry
Topic: Z-Wave v2.3.5 is out
Replies: 18
Views: 656

Re: Z-Wave v2.3.5 is out

I decided to test this 2.3.5 with my wall clock and some json files get quite large just in few days: ls -lsat /opt/z-way-server/automation/storage 1064 -rw-r--r-- 1 root root 1089011 Aug 4 18:59 notifications-f37bd2f66651e7d46f6d38440f2bc5dd.json 1524 -rw-r--r-- 1 root root 1558987 Aug 4 18:59 zway...
by timohan
30 Jul 2017 22:18
Forum: RaZberry
Topic: z-Way Server stops working
Replies: 44
Views: 5512

Re: z-Way Server stops working

Stress test is simple - as I have explained before: My system is pretty simple: I have two z-wave aeotec multisensor 6. They are configured to send data in every 10 seconds from their sensors to z-way server. + I have additional process that queries every 30 seconds from z-way-server by using these ...
by timohan
12 Jul 2017 19:59
Forum: RaZberry
Topic: z-Way Server stops working
Replies: 44
Views: 5512

Re: z-Way Server stops working

I have changed to homegenie and now everything seems to be stable. -> homegenie have been up 11 days already and things are looking good for my "wall clock" - no crashes, all performance levels are good, CPU usage is low as well on my stress testing. -> I may give a try for z-way-server later becaus...
by timohan
26 Jun 2017 18:00
Forum: RaZberry
Topic: z-Way Server stops working
Replies: 44
Views: 5512

Re: z-Way Server stops working

I made logging enabled again, and put my logs here before it started to slow down alot. * I also put my 2x multisensors push data only once in 2 minutes, but for some reason, data collection gets huge in 1.5 hours... seems some issues in data handling. Which is most likely reason for all these crash...
by timohan
25 Jun 2017 21:34
Forum: RaZberry
Topic: z-Way Server stops working
Replies: 44
Views: 5512

Re: z-Way Server stops working

Actually I had to reboot the raspberry pi eventually. I will give one more try for z-way-server, and then try other things if it crash. This time events are "hidden".
by timohan
25 Jun 2017 09:39
Forum: RaZberry
Topic: z-Way Server stops working
Replies: 44
Views: 5512

Re: z-Way Server stops working

Looks like my earlier modifications made z-way-server much more stable, but not fully. * Before modifications z-way-server crashed or caused a system crash in few hours due stress test. * Now z-way-server died after one week of running due stress test. -> I didn't need to do boot on raspberry pi, ju...
by timohan
18 Jun 2017 12:56
Forum: RaZberry
Topic: z-Way Server stops working
Replies: 44
Views: 5512

Re: z-Way Server stops working

Yes, the reason seems that large number of data is coming from Multisensors, and this causes multiple issues for raspberry pi & zway server. * I have those multisensors updating data in every 10 seconds. -> Sometimes when filesystem is writing alot data at the same time -> /dev/ttyAMA0 just stops re...
by timohan
17 Jun 2017 07:24
Forum: RaZberry
Topic: z-Way Server stops working
Replies: 44
Views: 5512

Re: z-Way Server stops working

There is another bug as well. My 2x aeotec multisensor 6 should send data to razberry (1) in every 10 seconds. but z-way-server seems to stop recognizing these multisensors after some time - sometimes it may take few hours, sometimes more, sometimes less. But after I reset /etc/init.d/z-way-server s...
by timohan
16 Jun 2017 16:15
Forum: RaZberry
Topic: z-Way Server stops working
Replies: 44
Views: 5512

Re: z-Way Server stops working

it's hanging and then it seems whole raspberry pi can crash. PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND 434 root 20 0 114220 38720 15736 S 100.2 4.1 0:44.20 z-way-server -> CPU usage have been all the way 100% long time. -> It "probably" have something to do with those curl calls I did pu...