Z-Cloud with Raspberry

Official announcements from Z-Wave.Me team. Check this forum to get information about new releases and bug fixes.
Post Reply
User avatar
PoltoS
Posts: 3817
Joined: 26 Jan 2011 19:36

Z-Cloud with Raspberry

Post by PoltoS » 03 Jan 2013 01:35

Many users ask us how to use Z-Cloud without keeping a running PC with Z-Agent all the time. The simpliest way is to use some router or embedded computer to run Z-Agent. Raspberry Pi is one of the best choice.Thanks to one of Z-Cloud user jussiva you don't need to compile Z-Agent anymore and do geek tricks - just follow the instruction.

caveguard
Posts: 10
Joined: 20 Feb 2013 22:02

razberry support

Post by caveguard » 03 Jan 2013 01:35

Hi

Could the file be adjusted for razbarry, even when changing to /dev/ttyAMA0 I get socket has gone .

Thanks,
Benjamin

User avatar
PoltoS
Posts: 3817
Joined: 26 Jan 2011 19:36

Are you sure you have

Post by PoltoS » 03 Jan 2013 01:35

Are you sure you have configured the port?

The RaZberry install script does it. Please check it for configuring AMA0.

caveguard
Posts: 10
Joined: 20 Feb 2013 22:02

Hi

Post by caveguard » 03 Jan 2013 01:35

Hi

Well the local http server works fine (z-way-server), in config.xml it states:
/dev/ttyAMA0
So when trying to configuring Run_Z-Agent.sh I changed the devices to :
-d /dev/ttyAMA0 "${@}"

But I get the following error:
[E] Socket has gone

I hope that helps, if you could point me in the right direction I would really appreciate it.

Benjamin




User avatar
PoltoS
Posts: 3817
Joined: 26 Jan 2011 19:36

Would be cool to see debug

Post by PoltoS » 03 Jan 2013 01:35

Would be cool to see debug output from z-agent: run Run_Z-Agent.sh with --debug.

Also make sure z-way-server is switched off during launch of Z-Connector, since they will combat for the same data comming from the port

caveguard
Posts: 10
Joined: 20 Feb 2013 22:02

Thanks

Post by caveguard » 03 Jan 2013 01:35

hi

Ahh I see zagent and server runnig at the same time= bad..... Now it connects ok, with zway server stopped.

CG.

andyson
Posts: 3
Joined: 29 Mar 2017 12:24

Re: Z-Cloud with Raspberry

Post by andyson » 29 Mar 2017 15:45

What bugs do you see with RaZberry? The backend is very stable right now. The UI will certainly be stripped to have only functional part (we will probably keep the map feature, but will not make it better, since the new UI will solve the problem).

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest