Page 1 of 1

Z-Way under Raspbian Stretch

Posted: 12 Feb 2018 13:33
by Z-Wave Support
Hello,

For some time now, the operating system Raspbian has only been officially made available as "Stretch".

Unfortunately, Z-Way doesn't work underneath it.

For it to work properly, a few files need to be installed as workaround, as long as Z-Way is not yet compiled for Stretch. We have summarized the installation in a script, which you have to run after setting up the operating system.

wget -q -O - support.zwave.eu/libs | sudo bash

Many greetings
Z-Wave Support

Re: Z-Way under Raspbian Stretch

Posted: 20 Feb 2018 21:45
by marco
It seems there is permission denied in downloading libraries.
Could you check please?

Re: Z-Way under Raspbian Stretch

Posted: 20 Feb 2018 23:59
by shupez
Hi,

I´ve installed Raspbian Stretch on my RPi2 and the above line "wget -q -O - support.zwave.eu/libs | sudo bash",
but when I type in the line "wget -q -O - razberry.z-wave.me/install | sudo bash" nothing happens.
It thinks for 2 sec, and then just the command prompt.

Re: Z-Way under Raspbian Stretch

Posted: 21 Feb 2018 03:37
by PoltoS

Re: Z-Way under Raspbian Stretch

Posted: 21 Feb 2018 14:45
by shupez
Ahaa...
Thanx M8 =)

Re: Z-Way under Raspbian Stretch

Posted: 27 Jun 2018 23:25
by DJay
Hi Guys, I hope you can help and appreciate the time you are investing.

I'm using a Raspberry Pi 3 B+
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian

I installed

Code: Select all

wget -q -O - support.zwave.eu/libs | sudo bash
then

Code: Select all

wget -q -O - razberry.z-wave.me/install | sudo bash
I can reach the login of Z-Wave but when I try to add a device I always get an error popup.
SmartHome UI - ERROR
Unable to load data
Also switching to ExpertUI shows up an Error message.
Z-Wave Expert UI - ERROR
Communication or binding error! Please login again or check system connectivity.

Adding or excluding a device doesn't work and besides the the error messages it's doing nothing. :(

When I run again

Code: Select all

wget -q -O - support.zwave.eu/libs | sudo bash
I now only get the Message "Raspbian Stretch system detected"

I hope you can help a newbie to get z-wave to work.
Thank you very much in advance.

Re: Z-Way under Raspbian Stretch

Posted: 30 Jun 2018 01:19
by lordchilli
DJay wrote:
27 Jun 2018 23:25
Hi Guys, I hope you can help and appreciate the time you are investing.

...
I had exactly the same problem. Please try this:
https://forum.z-wave.me/viewtopic.php?f=3422&t=28954

Re: Z-Way under Raspbian Stretch

Posted: 30 Jun 2018 13:16
by DJay
lordchilli wrote:
30 Jun 2018 01:19
I had exactly the same problem. Please try this:
https://forum.z-wave.me/viewtopic.php?f=3422&t=28954
I can't thank you enough. Bluetooth and baudrate was the missing part.
Thanks to your great step by step instruction, everything is working now as it should with z-wave.me razberry on my Pi 3 B+ stretch.

Many thanks.

Re: Z-Way under Raspbian Stretch

Posted: 09 Jul 2018 09:28
by venicenerd
Hey, silly question, but what is the default password to SSH into the admin account?