Losing title of scene ...

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
jet11x
Posts: 51
Joined: 29 Dec 2014 21:15

Losing title of scene ...

Post by jet11x » 30 Dec 2014 00:57

I'm pretty new to Rasberry and the z-wave board.
Having previously used X10 I wanted something better, z-wave sounded like it fitted the bill (mesh ...) and the DIY nature of Rasberry and the z-wave board is very appealing.

However, I'm a bit confused on use of scenes and scheduled events in the HA UI.
I created a LightScene and linked it to a ScheduledScene. The Scene also appeared as a widget which appeared to get orphaned when I deleted the scene to try and get the name of the scene to match the one selected in the scheduleScene. So I edited the json file to clean things up and that seemed to work.

However, I now find I can create a scene but the title is ignored, with widget given name "Light Scene 3" i.e. based on the id of the scene. I can add a title and it's saved in the json config file. However, when the z-wave-server starts up the title and description of the scene get deleted.

I also think there's some name/title cashing going on in the browser as name of deleted scenes appear and they only got corrected when I re-started the browser.

Loaded latest version of z-wave software today - reports as v2.0.0 for controller.

Any advice would be most appreciated.

User avatar
PoltoS
Posts: 5093
Joined: 26 Jan 2011 19:36

Re: Losing title of scene ...

Post by PoltoS » 31 Dec 2014 04:22

Please update to v2.0.1-rc7. This problem is fixed there.

jet11x
Posts: 51
Joined: 29 Dec 2014 21:15

Re: Losing title of scene ...

Post by jet11x » 31 Dec 2014 13:59

Thank you for your quick response.
I've loaded the RC as you suggested and that has certainly improved things.

A few more thoughts on this.

The scheduler module refers to the toggle widget that's created. To trace this back to the scene it goes with, the creator id has the title of the scene. So turning on a single light at a set time and off at another time has:
  • Schedule 1 -> Toggle 1 (creator Scene 1) -> Scene 1 (Switch 1 on)
    Schedule 2 -> Toggle 2 (creator Scene 2) -> Scene 2 (Switch 1 off)
To me seems a bit complicated, but I'm at the start of learning about Z-Way, so I'll see how I go. Perhaps I can create something simpler.

I'm finding names aren't updating in the browser (Firefox) when a name/tittle is changed - can fix by doing shift-refresh for the browser.

jet11x
Posts: 51
Joined: 29 Dec 2014 21:15

Re: Losing title of scene ...

Post by jet11x » 09 Oct 2016 12:53

I'm still finding that some scenes can't be referred to by the name e.g. when you want to refer to them the name isn't available but "Light Scene <id>" is available.

I just created a new scene and have that problem. I've see this problem on Chrome and Firefox.

I'm on the latest version - v2.2.3

User avatar
PoltoS
Posts: 5093
Joined: 26 Jan 2011 19:36

Re: Losing title of scene ...

Post by PoltoS » 09 Oct 2016 14:00

Can we get more details to reproduce it here

jet11x
Posts: 51
Joined: 29 Dec 2014 21:15

Re: Losing title of scene ...

Post by jet11x » 09 Oct 2016 14:08

Create a scene call "Test Scene" which turns on 1 light and save it.
You can then see "Test Scene" in the list of active apps

Then create a Schedule called "Test Schedule" and try to add "Test Scene" as a scene to activate.
In the drop down "Test Scene" isn't available, but "Light Scene 30" (or whatever new highest id is) is available.

User avatar
PoltoS
Posts: 5093
Joined: 26 Jan 2011 19:36

Re: Losing title of scene ...

Post by PoltoS » 09 Oct 2016 15:11

This looks like a misundertsanding.

There are two things to name: module and vDev. First is your Test Scene, second is Light Scene 30. In Schedule you need to list vDev.

jet11x
Posts: 51
Joined: 29 Dec 2014 21:15

Re: Losing title of scene ...

Post by jet11x » 09 Oct 2016 15:16

Thanks. I think this has come up before and I've managed to forget it. Shame vDevs don't get named automatically when created for scenes.

Post Reply