How to load older FW version

Discussions about Z-Way software and Z-Wave technology in general
fez
Posts: 64
Joined: 20 Jul 2015 23:03

How to load older FW version

Post by fez » 09 Mar 2017 00:43

I would like to load an older FW version, i.e. 5.04
I have now 5.07 so the web IF tells me I'm up to date.

How can this be done over the command line?
Where can I find the FW image files?

Thanks.

User avatar
Z-Wave Support
Posts: 230
Joined: 21 Oct 2016 15:49

Re: How to load older FW version

Post by Z-Wave Support » 09 Mar 2017 11:05

Hello,

it is not possible make a downgrade the razberry Firmware.

best regards
Z-Wave Support

fez
Posts: 64
Joined: 20 Jul 2015 23:03

Re: How to load older FW version

Post by fez » 09 Mar 2017 11:28

I see that is not possible over the web UI, but I see no technical reason why that shouldn't be possible.
I am pretty sure there is a way, so that is why I asked. Upgrade or downgrade, it is still an image load.
I made some backups with the FW 5.04, I loaded meanwhile the 5.07 and now I cant restore the settings, I get some errors.
I am not sure if the new FW has problems, or it is simply incompatible with backups created with previous versions, but I think its worh a try to downgrade.

So again, could you please give me some instructions on how the load the FW from the shell.

User avatar
PoltoS
Posts: 3736
Joined: 26 Jan 2011 19:36

Re: How to load older FW version

Post by PoltoS » 10 Mar 2017 00:15

Well, it is, but such files are not loaded on our server.

5.07 was proven to have restore working, so I believe the problem is not in the firmware. Logs might help. Also please provide the backup if possible. As last case may be remote access will be needed.

Do you use UZB or RaZberry?

Benny
Posts: 44
Joined: 25 Jan 2017 15:50

Re: How to load older FW version

Post by Benny » 10 Mar 2017 09:57

I'm also not possible to do a restore with Firmware 5.07.
Tried it on Razberrry 1 and 2 with 5.07. On Razberry 1 with Firmware 5.04 the Restore was possible.
The Backup was made with Firmware 5.07...

fez
Posts: 64
Joined: 20 Jul 2015 23:03

Re: How to load older FW version

Post by fez » 10 Mar 2017 10:38

Hi PoltoS, thanks for replying.

I use RaZberry

This is the the message in the z-way-server.log

Code: Select all

[2017-03-10 07:18:24.039] [I] [zway] Restoring controller from config/zddx/d420c93f-DevicesData.xml
[2017-03-10 07:18:24.531] [I] [zway] Adding job: Reset the controller
[2017-03-10 07:18:24.531] [D] [zway] SETDATA controller.data.controllerState = 20 (0x00000014)
[2017-03-10 07:18:24.531] [E] [zway] SDK is not supported. Upgrade your stick or contact Z-Way developers for more information
[2017-03-10 07:18:24.532] [D] [zway] SETDATA controller.data.controllerState = 0 (0x00000000)
[2017-03-10 07:18:24.534] [D] [zway] SENDING (cb 0x02): ( 01 04 00 42 02 BB )
[2017-03-10 07:18:24.536] [D] [zway] RECEIVED ACK
[2017-03-10 07:18:26.512] [D] [zway] RECEIVED: ( 01 04 00 42 02 BB )
[2017-03-10 07:18:26.512] [D] [zway] SENT ACK
[2017-03-10 07:18:26.512] [D] [zway] SETDATA controller.data.lastIncludedDevice = Empty
[2017-03-10 07:18:26.512] [D] [zway] SETDATA controller.data.lastExcludedDevice = Empty
[2017-03-10 07:18:26.512] [I] [zway] Job 0x42 (Reset the controller): Done
[2017-03-10 07:18:26.512] [D] [zway] Job 0x42 (Reset the controller): success
[2017-03-10 07:18:26.512] [I] [zway] Removing job: Reset the controller
[2017-03-10 07:18:46.645] [D] [zway] Job 0x42: deleted from queue
I would attach the complete log and the backup file but it looks like whatever extension I use for the files I get an error: The extension is not allowed.

I could email it to you or some other way if you tell me how.

User avatar
PoltoS
Posts: 3736
Joined: 26 Jan 2011 19:36

Re: How to load older FW version

Post by PoltoS » 11 Mar 2017 14:43

Oh, this is enough... I already see the problem.

Can you show few lines of the log on Z-Way start (lines with controller.data.SDK, controller.data.ZWProtocolMajor, controller.data.ZWProtocolMinor). We will add it in 2.3.1 asap.

As a workaround please do ip:8083/JS/Run/zway.controller.data.SDK="6.51.09" and then try to restore again

fez
Posts: 64
Joined: 20 Jul 2015 23:03

Re: How to load older FW version

Post by fez » 11 Mar 2017 19:10

The proposed workaround worked!
Thanks for that.

As for the data you requested (from the same log where I had the errors), I found only :

Code: Select all

[2017-03-10 07:16:10.451] [D] [zway] SETDATA controller.data.SDK = ""
[2017-03-10 07:16:10.451] [D] [zway] SETDATA controller.data.ZWlibMajor = 4 (0x00000004)
[2017-03-10 07:16:10.451] [D] [zway] SETDATA controller.data.ZWlibMinor = 38 (0x00000026)
...
[2017-03-10 07:16:10.522] [D] [zway] SETDATA controller.data.ZWVersion = 5 (0x00000005)
[2017-03-10 07:16:10.522] [D] [zway] SETDATA controller.data.ZWaveChip = "ZW0500"
I found no traces of:
controller.data.ZWProtocolMajor, controller.data.ZWProtocolMinor

User avatar
PoltoS
Posts: 3736
Joined: 26 Jan 2011 19:36

Re: How to load older FW version

Post by PoltoS » 11 Mar 2017 21:13

Yup, these are correct. Thanks, will be fixed in next release.

Willem_K
Posts: 5
Joined: 09 May 2017 11:07

Re: How to load older FW version

Post by Willem_K » 11 May 2017 12:16

After upgrade of my UZB to firmware 5.07 it is not working anymore, the stick is recognised but adding nodes is not possible, it causes a crash and I have to a restart it. What can I do to 'revive' it?

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests