Device Database Location

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
Posts: 1
Joined: 07 Apr 2017 18:30

Device Database Location

Post by dansampson » 07 Apr 2017 18:37

I have two razberry controllers. I am installing the first alert smoke alarm (among other devices). Since it will never pass the install process because it has older security settings, I have gone ahead and altered my /config/zddx/DevicesData.xml and /automation/storage/configjson-***.json files accordingly.

After I have made these changes the smoke alarm works as expected on my first controller. But what I take those same settings and manually input them into these files on the second controller, the device does not get added.

Before I alter these files, I run:
$ sudo service z-way-server stop

And after I write the files I run:
$ sudo service z-way-server save
$ sudo service z-way-server start

My question is there appears to be another file, or database that is used by the z-way-server to actually add and manage the devices on the network. Is this the case? If so, where is this located and how can I access it?

If that isn't the case, any suggestions why my configuration changes don't appear to be saving?

Post Reply