z-way-server does not start in Stretch

Discussions about Z-Way software and Z-Wave technology in general
ofuangka
Posts: 9
Joined: 21 Nov 2015 18:22

z-way-server does not start in Stretch

Post by ofuangka » 22 Aug 2017 03:22

It looks like there isn't a package in Stretch for libssl1.0.0. Are there plans to upgrade to libssl1.0.2?

User avatar
PoltoS
Posts: 3838
Joined: 26 Jan 2011 19:36

Re: z-way-server does not start in Stretch

Post by PoltoS » 26 Aug 2017 08:56

It is pretty hard to support many variants of libraries. May be once we see that this version will become part of Jessie

jeey
Posts: 13
Joined: 06 Mar 2016 06:44

Re: z-way-server does not start in Stretch

Post by jeey » 26 Aug 2017 13:27

Paltos jessie will not get updated libssl version, jessie is slowly going to die the same way as wheezy did.

Stretch is the new raspian base and in the forthcomming month z-way should be updated to support it as jessie would not get security updates as normal debian do.

dodobibi
Posts: 5
Joined: 24 Aug 2017 13:31

Re: z-way-server does not start in Stretch

Post by dodobibi » 27 Aug 2017 00:31

zway libraries need libssl1.0.0 but raspbian stretch give libssl1.0.2.

a workaround consist to download and install this library (from raspbian jessie):

Code: Select all

wget http://mirrordirector.raspbian.org/raspbian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb
sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb
Waiting for razberry update it's code to support libssl1.0.x...

User avatar
PoltoS
Posts: 3838
Joined: 26 Jan 2011 19:36

Re: z-way-server does not start in Stretch

Post by PoltoS » 27 Aug 2017 00:37

The code supports a more modern library, but just switching to the new one will kill Z-Way on all Jessie. So we need to make some workaround here. Still thinking how to proceed forward...

vlad
Posts: 31
Joined: 19 Oct 2016 04:58

Re: z-way-server does not start in Stretch

Post by vlad » 01 Sep 2017 04:18

Just compile it twice (one for Jessie and one for Stretch) and load as needed correct z-way-server tarball.

Otherwise you will see more and more frustration coming up from your new users and old one those who decided to do upgrade.

User avatar
larsskj
Posts: 9
Joined: 01 Sep 2017 00:20

Re: z-way-server does not start in Stretch

Post by larsskj » 01 Sep 2017 14:19

Hi Polto,
PoltoS wrote:
27 Aug 2017 00:37
So we need to make some workaround here. Still thinking how to proceed forward...
The right solution would be to build proper Debian packages and add them to a repository - like Bintray. You should build two different packages, one for Jessie and another one for Stretch - apt-get would then choose the right one automatically.

It's no problem at all with a modern build system - I'm doing it daily.

Regards,
Lars
Best regards,
Lars

Plainsane
Posts: 80
Joined: 20 Apr 2015 01:22

Re: z-way-server does not start in Stretch

Post by Plainsane » 03 Sep 2017 17:06

yea i just upgraded to stretch, would be cool to get it working there. im wrestlhing with libarchive as well

jhmartin
Posts: 29
Joined: 14 Apr 2015 02:52

Re: z-way-server does not start in Stretch

Post by jhmartin » 14 Nov 2017 07:49

The standard Raspberry installer 'NOOBS' no longer offers Jessie as an option and now only supplies Stretch. Trying to install the jessie library above only resulted in Illegal Instructions when trying to launch the server. This is now an issue for me as a power blip corrupted my instance and I need to reinstall :< . With Jessie on the wane please consider building a Stretch-compatible edition.

In fact, https://www.raspberrypi.org/downloads/raspbian/ does not offer Jessie at all anymore.

gabrielb
Posts: 13
Joined: 17 Dec 2015 23:45
Location: Sweden

Re: z-way-server does not start in Stretch

Post by gabrielb » 20 Nov 2017 20:34

jhmartin wrote:
14 Nov 2017 07:49
The standard Raspberry installer 'NOOBS' no longer offers Jessie as an option and now only supplies Stretch. Trying to install the jessie library above only resulted in Illegal Instructions when trying to launch the server. This is now an issue for me as a power blip corrupted my instance and I need to reinstall :< . With Jessie on the wane please consider building a Stretch-compatible edition.

In fact, https://www.raspberrypi.org/downloads/raspbian/ does not offer Jessie at all anymore.
You can find the images here...
http://downloads.raspberrypi.org/raspbian_lite/images/

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests