Version 2.3.6

Discussions about Z-Way software and Z-Wave technology in general
timb
Posts: 50
Joined: 03 Jan 2015 00:10

Version 2.3.6

Post by timb » 25 Sep 2017 21:51

I can see that you are working on version 3.0.0 - great!
The last official release is 2.3.5
But I see 2.3.6.... Please can you explain what this is.

Is it a release to fix bugs in 2.3.5 without new features?
If so, there are only rc versions - so are they any good to use? Normally I avoid rc versions.

Second questions: and it's bugged me for ages..... How do I search the forum for a specific version e.g. 2.3.5. If I put "2.3.5" in the search string the forum software strips out the "." Is there is search syntax where I can specify the dot e.g. "." or /. ??

Thanks,
Tim

User avatar
PoltoS
Posts: 4055
Joined: 26 Jan 2011 19:36

Re: Version 2.3.6

Post by PoltoS » 26 Sep 2017 02:22

v3.0.0 is the one with the new Z-Wave Security S2 support. Please use it ONLY if you have S2 devices and you are brave enough to test new features.

v2.3.6 will fix bugs from v2.3.5 and ann some new features.

Not sure how to search in this phpBB ;) Sometimes I'm puzzled too...

timb
Posts: 50
Joined: 03 Jan 2015 00:10

Re: Version 2.3.6

Post by timb » 05 Dec 2017 23:18

I have been running with 2.3.6 now since it was released.
I have had on-going reliability issues.
After 2-3 days the Pi becomes unresponsive. By this I mean:
> zwave apps no longer triggering e.g. rules
> zwave url unresponsive
> cannot even connect to raspberry through VNC
The only remedy is to reboot the pi - not nice!
As I say I have to do this every 2-3 days. It means I can't rely on the zway any more!

User avatar
PoltoS
Posts: 4055
Joined: 26 Jan 2011 19:36

Re: Version 2.3.6

Post by PoltoS » 08 Dec 2017 09:00

Can you keep ssh connected and check what happens ? May be memory issue?

User avatar
larsskj
Posts: 9
Joined: 01 Sep 2017 00:20

Re: Version 2.3.6

Post by larsskj » 09 Dec 2017 11:10

Hi Tim.
timb wrote:
05 Dec 2017 23:18
I have been running with 2.3.6 now since it was released.
I have had on-going reliability issues.
After 2-3 days the Pi becomes unresponsive.
I have exactly the same issues - though I can add that zway corrupts the filesystem on my Raspberry Pi.
It means I can't rely on the zway any more!
That's about the conclusion I'm nearing as well. :cry:
Best regards,
Lars

User avatar
PoltoS
Posts: 4055
Joined: 26 Jan 2011 19:36

Re: Version 2.3.6

Post by PoltoS » 10 Dec 2017 00:16

Can you help us give some more valuable debug info?

Z-Way works for many thousands of users daily (I have it at home too) and they restart it only once per quarter to install updates.

Just complaining that it does not work, hang your Pi or corrupt filesystem or eat you food will not help us to make it more stable. We need more I formation like detailed info about your config (what additional apps do you have), gdb traces, or other useful info.

I still use RPi B (the oldest one) and even there the flash card have never crashed and the box do not hang.

User avatar
larsskj
Posts: 9
Joined: 01 Sep 2017 00:20

Re: Version 2.3.6

Post by larsskj » 10 Dec 2017 11:39

Hi Polto,
PoltoS wrote:
10 Dec 2017 00:16
Can you help us give some more valuable debug info?
Yes, I hope so: What do you want? (I'm a professional software developer and, most of all, a DevOps).
Just complaining that it does not work, hang your Pi or corrupt filesystem or eat you food will not help us to make it more stable.
Of course not: But it might help you to understand that Z-Way doesn't work perfectly well for all of us. And initiate a dialogue, I hope. Seems I succeeded on the latter part.
We need more I formation like detailed info about your config (what additional apps do you have), gdb traces, or other useful info.
How do I provide that in a form useful to you?

Just had to reinstall my Z-Way again last night: It's simply running the latest Raspian Jessie and Z-Way running on a RPi 3 - nothing else. The former install did the same - it lasted for around a week before I had file system corruption.
Attachments
zway-apps.png
zway-apps.png (146.77 KiB) Viewed 1498 times
Best regards,
Lars

User avatar
PoltoS
Posts: 4055
Joined: 26 Jan 2011 19:36

Re: Version 2.3.6

Post by PoltoS » 10 Dec 2017 13:10

If it comes to crashes of the fs, would be nice to see your logs from last week. It is huge, but I want to compare it with the usual number of events synced to the filesystem.

Are you sure Z-Way is causing it? May be RPi or SD card failure lead to this?

We need your backup both from EUI Nd SHUI to see your devices and your apps running.

My be you have many devices reporting ever 10 seconds that lead to constant fs sync. Or some app that does this?

User avatar
larsskj
Posts: 9
Joined: 01 Sep 2017 00:20

Re: Version 2.3.6

Post by larsskj » 10 Dec 2017 13:29

Hi Polto,
PoltoS wrote:
10 Dec 2017 13:10
If it comes to crashes of the fs, would be nice to see your logs from last week. It is huge, but I want to compare it with the usual number of events synced to the filesystem.
I don't have the logs, the file system crashed and I couldn't read anything from it - nor could I boot the system: Raspian simply halted with a complaint that the root filesystem was corrupted.
Are you sure Z-Way is causing it? May be RPi or SD card failure lead to this?
As I wrote in another thread: I've tried three different SD cards and two different RPi. I have around ten RPi running in the house for various purposes, the other works just fine. At work we have numerous other RPi running - the only time I've seen this behaviour is on my Z-Way system.
We need your backup both from EUI Nd SHUI to see your devices and your apps running.
I'm afraid I don't know what EUI and SHUI is - but maybe you mean the attached backups?
My be you have many devices reporting ever 10 seconds that lead to constant fs sync. Or some app that does this?
Not that I know of - but I'm not an expert on Z-Way, so it might be the case, of course.

(Just tried to attach backup files to this reply : phpBB refuses to accept .zab and .zbk files. You need to enable this in the phpBB setup)

(Then tried to create a zip archive with the backup files and the current log - this time phpBB complains that the attachment is too large: How do I send these files to you?)
Best regards,
Lars

timb
Posts: 50
Joined: 03 Jan 2015 00:10

Re: Version 2.3.6

Post by timb » 10 Dec 2017 17:10

Hi PoltoS
Thank you for replying.

Let me try to give you some more information...

The problems have only started after installing 2.3.6.
2.3.5 ran reliably for weeks, so did 2.3.6rc6
I am running on a clean Raspbian Strech and Z-Way running on a RPi 3 - nothing else happening on the Pi, dedicated to zwave
I have not changed the configuration in anyway, just upgraded.

When the system becomes unresponsive, I cannot access the URL, neither can I access with VNC and the system is not following the apps I have set up e.g. Rules, Cron.
I haven't tried SSH - but will do next time.

The file system does not get corrupt, because a simple re-boot brings the system back to life.
I have tried reinstalling 2.3.6 over the top of the existing install - makes no difference.

The apps I am using are:
Automated switch off
Battery polling
Association
Counter
Cron
Delayed Action
Dummy device
Http device
If
Inband notifier
IntChart
Scene
Logical rules
Low battery notification
Send EMail notification
Mobile App support
Pushbullet
Remote Access
Schedule
Perioical Sensor polling (disabled)
Trap events
Tag devices
Zwave network access

Not sure if it is relevant, but using Expert - the Routing page does not work (completely blank) - it did work in 2.3.6rc6

Meanwhile I am going to install 2.3.6 on my secondary Pi controller to see what that is like.


I would be happy to send any debug information that I can - what exactly would you like? Please let me know.
Thanks

Post Reply