Z-Uno not working anymore

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
dawiinci
Posts: 48
Joined: 14 Oct 2017 10:54

Z-Uno not working anymore

Post by dawiinci » 26 Apr 2018 17:19

My Z-Uno stopped working I only get the green led blinking and I can't flash or upload the boot loader.
Resetting doesn't help (5s on RST then three times tap).

Any advice? Is the module broken?

Code: Select all

Arduino: 1.8.5 (Mac OS X), Board: "Z-Wave>ME Z-Uno, Europe, Disabled, Enabled, Disabled, Disabled"

...
java.io.IOException: Cannot run program "___REMOVE___/zuno_toolchain/compiler": error=2, No such file or directory
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
	at java.lang.Runtime.exec(Runtime.java:620)
	at java.lang.Runtime.exec(Runtime.java:485)
	at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:11)
	at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:129)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:207)
	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
	at processing.app.SketchController.upload(SketchController.java:713)
	at processing.app.SketchController.exportApplet(SketchController.java:686)
	at processing.app.Editor$DefaultExportHandler.run(Editor.java:2168)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.IOException: error=2, No such file or directory
	at java.lang.UNIXProcess.forkAndExec(Native Method)
	at java.lang.UNIXProcess.<init>(UNIXProcess.java:247)
	at java.lang.ProcessImpl.start(ProcessImpl.java:134)
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
	... 10 more

itstrisha
Posts: 9
Joined: 07 Apr 2018 13:25

Re: Z-Uno not working anymore

Post by itstrisha » 27 Apr 2018 13:56

Even I came across the same problem but still no idea whether the module is broken or not.

dawiinci
Posts: 48
Joined: 14 Oct 2017 10:54

Re: Z-Uno not working anymore

Post by dawiinci » 28 Apr 2018 08:40

After I updated the board I was able to upload the new boot loader. Its works again...

Don't know why it stopped working since nothing changed.

sachinkhanna48
Posts: 1
Joined: 29 Jul 2018 15:45

Re: Z-Uno not working anymore

Post by sachinkhanna48 » 29 Jul 2018 15:46

having same problem

Post Reply