v2.3.8 issues with UZB

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
jswim788
Posts: 22
Joined: 12 Sep 2016 23:40

v2.3.8 issues with UZB

Post by jswim788 » 19 Nov 2018 05:08

I just upgraded to v2.3.8 and I have lost control of all devices. The z-way log looks okay at the start, but I cannot control any device after it starts. It appears that the UZB cannot communicate with any device. Can I downgrade to 2.3.6 where I started? Any debug ideas? Sample section of log below.

[2018-11-18 18:01:49.463] [core] Notification: error (connection): Connection lost to Z-Wave device ID: 14
[2018-11-18 18:01:49.493] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2018-11-18 18:01:49.493] [D] [zway] SENT ACK
[2018-11-18 18:01:49.493] [D] [zway] Delivered to Z-Wave stack
[2018-11-18 18:01:51.536] [W] [zway] Reply not received before timeout for job (SwitchBinary Get)
[2018-11-18 18:01:55.308] [D] [zway] Job 0x13: deleted from queue
[2018-11-18 18:01:55.948] [D] [zway] RECEIVED: ( 01 07 00 13 45 01 02 8D 20 )
[2018-11-18 18:01:55.948] [D] [zway] SENT ACK
[2018-11-18 18:01:55.948] [zway] Job 0x13 (SwitchBinary Get): Not delivered to recipient
[2018-11-18 18:01:55.949] [D] [zway] SENDING (cb 0x46): ( 01 0D 00 13 12 06 56 01 25 02 B2 D3 25 46 87 )
[2018-11-18 18:01:55.959] [D] [zway] RECEIVED ACK
[2018-11-18 18:01:56.022] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2018-11-18 18:01:56.022] [D] [zway] SENT ACK
[2018-11-18 18:01:56.022] [D] [zway] Delivered to Z-Wave stack
[2018-11-18 18:02:02.482] [D] [zway] RECEIVED: ( 01 07 00 13 46 01 02 8C 22 )
[2018-11-18 18:02:02.482] [D] [zway] SENT ACK
[2018-11-18 18:02:02.483] [zway] Job 0x13 (SwitchBinary Get): Not delivered to recipient
[2018-11-18 18:02:02.483] [D] [zway] SENDING (cb 0x47): ( 01 0D 00 13 12 06 56 01 25 02 B2 D3 25 47 86 )
[2018-11-18 18:02:02.492] [D] [zway] RECEIVED ACK
[2018-11-18 18:02:02.556] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2018-11-18 18:02:02.556] [D] [zway] SENT ACK
[2018-11-18 18:02:02.556] [D] [zway] Delivered to Z-Wave stack
[2018-11-18 18:02:08.949] [D] [zway] RECEIVED: ( 01 07 00 13 47 01 02 87 28 )
[2018-11-18 18:02:08.949] [D] [zway] SENT ACK
[2018-11-18 18:02:08.949] [zway] Job 0x13 (SwitchBinary Get): Not delivered to recipient
[2018-11-18 18:02:08.949] [zway] Job 0x13 (SwitchBinary Get): Removing job due to too much retransmitions
[2018-11-18 18:02:08.950] [D] [zway] SETDATA devices.18.data.failureCount = 2 (0x00000002)
[2018-11-18 18:02:08.950] [D] [zway] SETDATA devices.18.data.lastSendInternal = **********
[2018-11-18 18:02:08.950] [D] [zway] Job 0x13 (SwitchBinary Get): fail
[2018-11-18 18:02:08.950] [zway] Waiting for job reply: SwitchBinary Get
[2018-11-18 18:02:08.950] [D] [zway] SENDING (cb 0x48): ( 01 0D 00 13 19 06 56 01 25 02 B2 D3 25 48 82 )
[2018-11-18 18:02:08.951] [D] [zway] RECEIVED ACK
[2018-11-18 18:02:08.958] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2018-11-18 18:02:08.958] [D] [zway] SENT ACK
[2018-11-18 18:02:08.958] [D] [zway] Delivered to Z-Wave stack
[2018-11-18 18:02:08.988] [core] Notification: error (connection): Connection lost to Z-Wave device ID: 18
[2018-11-18 18:02:11.066] [W] [zway] Reply not received before timeout for job (SwitchBinary Get)
[2018-11-18 18:02:11.838] [D] [zway] Job 0x13: deleted from queue
[2018-11-18 18:02:14.483] [D] [zway] RECEIVED: ( 01 07 00 13 48 01 02 29 89 )
[2018-11-18 18:02:14.483] [D] [zway] SENT ACK
[2018-11-18 18:02:14.483] [zway] Job 0x13 (SwitchBinary Get): Not delivered to recipient
[2018-11-18 18:02:14.483] [D] [zway] SENDING (cb 0x49): ( 01 0D 00 13 19 06 56 01 25 02 B2 D3 25 49 83 )
[2018-11-18 18:02:14.488] [D] [zway] RECEIVED ACK
[2018-11-18 18:02:14.490] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2018-11-18 18:02:14.490] [D] [zway] SENT ACK
[2018-11-18 18:02:14.491] [D] [zway] Delivered to Z-Wave stack
[2018-11-18 18:02:20.016] [D] [zway] RECEIVED: ( 01 07 00 13 49 01 02 29 88 )
[2018-11-18 18:02:20.016] [D] [zway] SENT ACK
[2018-11-18 18:02:20.016] [zway] Job 0x13 (SwitchBinary Get): Not delivered to recipient
[2018-11-18 18:02:20.017] [D] [zway] SENDING (cb 0x4a): ( 01 0D 00 13 19 06 56 01 25 02 B2 D3 25 4A 80 )
[2018-11-18 18:02:20.022] [D] [zway] RECEIVED ACK
[2018-11-18 18:02:20.025] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2018-11-18 18:02:20.025] [D] [zway] SENT ACK
[2018-11-18 18:02:20.025] [D] [zway] Delivered to Z-Wave stack
[2018-11-18 18:02:25.592] [D] [zway] RECEIVED: ( 01 07 00 13 4A 01 02 2D 8F )
[2018-11-18 18:02:25.592] [D] [zway] SENT ACK
[2018-11-18 18:02:25.592] [zway] Job 0x13 (SwitchBinary Get): Not delivered to recipient
[2018-11-18 18:02:25.593] [I] [zway] Job 0x13 (SwitchBinary Get): Removing job due to too much retransmitions
[2018-11-18 18:02:25.593] [D] [zway] SETDATA devices.25.data.failureCount = 2 (0x00000002)
[2018-11-18 18:02:25.593] [D] [zway] SETDATA devices.25.data.lastSendInternal = **********
[2018-11-18 18:02:25.593] [D] [zway] Job 0x13 (SwitchBinary Get): fail
[2018-11-18 18:02:25.593] [I] [zway] Waiting for job reply: SwitchBinary Get
[2018-11-18 18:02:25.619] [I] [core] Notification: error (connection): Connection lost to Z-Wave device ID: 25
[2018-11-18 18:02:27.728] [W] [zway] Reply not received before timeout for job (SwitchBinary Get)

jswim788
Posts: 22
Joined: 12 Sep 2016 23:40

Re: v2.3.8 issues with UZB

Post by jswim788 » 19 Nov 2018 06:03

In addition, I see a few of these in the log after the switch to v2.3.8, but they don't appear to be related to the main issue of communication noted above:

[2018-11-18 19:01:52.248] [core] Creating device doorlock ZWayVDev_zway_17-0-98
[2018-11-18 19:01:52.296] [core] Notification: error (core): Cannot create vDev based on: 17-0-113: TypeError: undefined is not a function
[2018-11-18 19:01:52.297] [core] TypeError: undefined is not a function

jswim788
Posts: 22
Joined: 12 Sep 2016 23:40

Re: v2.3.8 issues with UZB

Post by jswim788 » 19 Nov 2018 06:09

I may have solved this. Somehow the upgrade seemed to have set the Z-wave frequency to EU. Once I switched it to 'US' it started to work again. I'll check for any other issues.

Post Reply