Zway on Ubuntu with UZB remote access: path to ZBWConnect / Zway platform ID?

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
dirkhas
Posts: 1
Joined: 22 Nov 2018 21:13

Zway on Ubuntu with UZB remote access: path to ZBWConnect / Zway platform ID?

Post by dirkhas » 22 Nov 2018 21:37

I've installed zway on my ubuntu 18.04 server from https://oldrazberry.z-wave.me/z-way-ser ... v2.3.8.tgz.

I've simply unpacked the file, and run it with

Code: Select all

LD_LIBRARY_PATH=./libs ./z-way-server
I have an UZB stick and a license. I can connect to zway on my LAN using http://<IP>:8083 using both web and the android app, and I've succesfully connected three thermostats -- this part is working fine.

However, I cannot for the life of me find out how to gain remote access.
  1. Logging in, I have no Zway platform ID as it says in the manual -- it is not shown in the login window. I assume this might be related to the fact that "Remote Access" does not seem to be enabled out-of-the-box in Ubuntu?
  2. When I try to add "Remote Access" from the local apps section, I'm asked to point to the "Absolute path to ZBWConnect on server". I have no zbw binary anywhere. How do I install that?
  3. Leaving the path empty in the previous step, when I go to Management --> Remote Access, I get an error telling me "Can't initialize remote access data. Please deactivate/activate it in Apps-Active tab."
  4. I see this exists: https://oldrazberry.z-wave.me/z-way-ser ... .1_all.deb. Is that the ZBWConnect component, I'm missing? It fails install because it depends on a "z-wave-server" package, which of course does not exist since there is no deb package for Ubuntu.
Suggestions? What am I missing? What do I need to do to enable remote access via find.z-wave.me?

User avatar
PoltoS
Posts: 4334
Joined: 26 Jan 2011 19:36

Re: Zway on Ubuntu with UZB remote access: path to ZBWConnect / Zway platform ID?

Post by PoltoS » 04 Dec 2018 00:34

Remote access is not possible on Ubuntu. You should do your own OpenVPN or similar

Post Reply