Page 1 of 2

Can not remove associations in Expert UI

Posted: 17 Jan 2019 01:33
by brusan
Hi,

Running v2.3.8 with UI v1.9.0 under Razberry.

I made an experimental setup with a Fibaro Dimmer 2 and a WallMote Quad to test group associations. After realizing that unless both devices involved in a group association has the same security scheme, the association will not work, I excluded the WallMote from the system in order to do a new inclusion of it, this time with security enabled. During the test, I also erroneously created several associations from the Fibaro dimmer to the WallMote, in reverse to what is correct.

Before including the WallMote, I needed to remove the associations I created during the test. It turns out that this is not doable in the expert UI. I open Device and Active associations and find the associations listed for the Fibaro device. Clicking "Change" only leads me to the Association page for the Fibaro Device and there are no associations listed there other than the Life line associations to the Z-Way.

How do I remove associations in Z-wave.me?

Including screen shots of the UI.
The attachment fibaro associations.PNG is no longer available
fibaro associations.PNG
fibaro associations.PNG (14.56 KiB) Viewed 1772 times

Re: Can not remove associations in Expert UI

Posted: 17 Jan 2019 17:37
by brusan
Just to add to the above, it seems a bit strange that associations for devices that have been excluded (=removed from the controller) remains in the UI as is the case with device #31 above.

Trying once more to include the screen dump...
fibaro device.PNG
fibaro device.PNG (91.82 KiB) Viewed 1750 times

Re: Can not remove associations in Expert UI

Posted: 17 Jan 2019 19:46
by enbemokel
Hi, I have an equal problem, can´t change or delete associations from my Aeotec Wall Quad:

Re: Can not remove associations in Expert UI

Posted: 17 Jan 2019 19:48
by enbemokel
If I click the button on the right side "Change" and enter the Expert Menu, there is nothing shown. Only the Z-Way lifeline....
Strange

Re: Can not remove associations in Expert UI

Posted: 18 Jan 2019 00:43
by PoltoS
Gonin Configuration/your device/associations

Re: Can not remove associations in Expert UI

Posted: 18 Jan 2019 13:35
by enbemokel
Hi Polto, did it, nothing to see or to do. I also can´t set a new association, as the device 10 isn´t shown in the menu.
Any idea?

Re: Can not remove associations in Expert UI

Posted: 19 Jan 2019 17:24
by brusan
[tag]PoltoS[/tag] "Gonin Configuration/your device/associations" does not help at all, the associations does not appear there. They are shown if I go Device/Active Associations but not via Configuration/select device/Association. Does not matter if I wake up the Wall Quad or not, nothing there.
I have also tried to restart the entire Raspberry Pi - no change for the better.

Can I remove the associations via the API like
[ip]:8083/JS/Run/zway.devices[nodeId].Association.Remove(GroupId, AssocNodeId) or if it is a multi:
[ip]:8083/JS/Run/zway.devices[nodeId].MultiChannelAssociation.Set(GroupId, AssocNodeId, AssocInstanceId)

I have temporarily "solved" the problem by deleting (exclude) the devices in question but I'm not confident there are no dangling associations lurking in the system? I think there used to be a file somewhere where all the associations was listed but I can not find it any more.

Br / Brusan

Re: Can not remove associations in Expert UI

Posted: 03 Feb 2019 22:00
by brusan
I think there is a bug in the listing of active associations. Include one example of device #44 that according to the list of active associations, have two active associations. When clicking the "Change" icon the association page for the device #44 is shown but there are no associations listed?! This seems like a bug to me.
The attachment Unit_ActiveAssociations.PNG is no longer available
Unit_ActiveAssociations.PNG
Unit_ActiveAssociations.PNG (12.71 KiB) Viewed 1614 times

Re: Can not remove associations in Expert UI

Posted: 03 Feb 2019 22:07
by brusan
Could not get image 2 to show up in the thread. Trying to put it here:
Unit44_List_of_associations.PNG
Unit44_List_of_associations.PNG (96.54 KiB) Viewed 1614 times

Re: Can not remove associations in Expert UI

Posted: 19 Feb 2019 14:03
by brusan
I'm still having problems with associations that point to devices that no longer exist and the fact that current associations are not listed on the Associations tab in Expert view. I really need some advice here...