Z/IP Gateway LAN Communications

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
raja50
Posts: 3
Joined: 15 Nov 2018 09:46

Z/IP Gateway LAN Communications

Post by raja50 » 11 Feb 2019 16:24

Hello ,
Currently I am planning to connect my Z-Wave DEvices with Gateway(Beaglebone)

As mentioned in all the Installation are done from the link
https://www.silabs.com/support/getting- ... roller-kit

(I HAVE ATTACHED MY PLAN IN THE SECOND fIGURE:)

After building the documentation I habe downloaded the Z-Ware SDK 1.11 and Inside this file I have taken the source code from (Z-Ware SDK 1.11\src\zwportal\src\zwave\hcapi) and in the Visual Studio 2017 (Window 7) I have run the given programm zipctl. After running the program I have got the following Problems( Please refer to Fig:Error) .How to solve this problem/Error?
My Questions:

1) Am I in the right path to develop my Programm ?Is this the source Code which leads me to connect the Z-Wave devices with ZIPGateway(In My case Beaglebone Black)?

2) what are the steps to connect Gateway with my Programm? What specific Datei (middleware or somethings else .....) is needed so that I can call the functions of Z-Wave Devices in another Programming Language ?

3) How can I set the IP destination on gateway?

4) What exactly should I use from command class specification

https://www.silabs.com/products/wireles ... cification

this link gives me the users Guide , but I am unable to find the right datei/folders which should be Installed /used in the Project. Thank you for your Help .


Best Regards
Raja
Attachments
Plan.jpg
Plan.jpg (104.52 KiB) Viewed 225 times
Errors.PNG
Errors.PNG (24.66 KiB) Viewed 225 times

Post Reply