Failed to load config.xml after update 3.0.0

Discussions about Z-Way software and Z-Wave technology in general
Confuzer
Posts: 10
Joined: 19 Jun 2014 12:55

Re: Failed to load config.xml after update 3.0.0

Post by Confuzer » 27 Sep 2019 04:46

Tried that:

The following packages have unmet dependencies:
z-way-server : Depends: libssl1.0.2 (>= 1.0.2) but it is not installable

PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"

:(

Then you get in cross compilation update hell. I have a month old backup (luckily). I will save my db, commit my latest code and revert. Seems I need to update, safely, to stretch first? Anyone have save update instructions for that? Not willing to do fresh install as my setup is full of tweaks.

(got a step further now with the instructions, everything broke as I had a different Python version linked. But I need that... so *&^*&@# fragile these OS types)


Edit: enbemokel thanks! Got it to work after a few hickups :)

z-wavettaja
Posts: 15
Joined: 02 Nov 2017 18:49

Re: Failed to load config.xml after update 3.0.0

Post by z-wavettaja » 14 Oct 2019 21:38

enbemokel wrote:
26 Sep 2019 16:20
Funny, I upgraded weeks ago, everything worked fine. Then I did something...don´t remember what I did...and, couldnt log in...
then i found a detailed upgrade command and everything was back:
sudo apt-get --reinstall install -o Dpkg::Options::="--force-confmiss" -o Dpkg::Options::="--force-confold" -y z-way-server
Excatly what happened here also! But thanks to you I got my system back to running with your command 8-)

Post Reply