Z-way-Backup -> replace RaZBerry -> Restore FAILED !!!

Post Reply
simonchase
Posts: 7
Joined: 30 Nov 2015 12:30

Z-way-Backup -> replace RaZBerry -> Restore FAILED !!!

Post by simonchase » 30 Nov 2015 13:04

Hallo liebe Forengemeinde,

mein erstes Posting hier hat gleich mit einem riesigen Problem zu tun. Ich betreibe mein Zwave-Netzwerk mit einem Raspberry Pi 2 + RazBerry-Controller-Board. Im Netzwerk sind über 25 unterschiedliche Nodes ( von Fibaro FGRM-222, Fibaro Wallplugs, DanFoss Thermostaten, Rauchmelder, MotionDetector, switches etc.) verbaut + Z-Way-Server V2.1.1. Alles funktionierte bis vor 2 Tagen wunderbar. Dann hat nach knapp 1,2 Jahren das RazBerry-Board den Geist aufgegeben.

Ich kann somit nicht mehr auf mein Netzwerk zugreifen ! Das witzige :evil: an der Sache ist, dass aufgrund der Gruppierungen und Abhängigkeiten zwischen den einzelnen Nodes, Funktionen wie z.B.: Schliessen oder Öffnen der Rolläden bei Auslösen vom Bewegungsmelder trotzdem noch funktionieren :). Der Rest jedoch nicht ! :oops:

Wie bei jedem Projekt, hab ich auch hier mit der Z-Way-Software (nach jedem Update der Server-SOFTWARE) ein Backup des bestehenden Netzwerkes angefertigt, um, wie man es denn erwartet, in einem solchen Falle schnell wieder handlungsfähig mit einem neuen Controller (auch wieder RazBerry) zu sein.

Zum Hauptproblem: Das Backup welches ich vorsorglich angelegt habe, ist seinem Namen in keinster Weise wert !!!!!!! Nach 'Montage' des neuen RazBerry-Boards (gleiche Hard- und Software-Revision), versuchte ich ein Restore über das WebFrontend zu starten. Mit dem Ergebnis: 'Das Backup-File ist ungültig!'. Ich habe es mit jeder Version meiner Backups versucht, aber keinen Erfolg gehabt !!! :( :oops: :oops:

Meine Frage: gibt es eine Möglichkeit meine alte homeID manuell wiederherzustellen und wie gewohnt weiter zu arbeiten? Wenn nicht, würde dies bedeuten, ich müsste alle!! ZWave-Geräte zurücksetzen und in ein neues Netzwerk einbinden, meine komplette Konfiguration incl. JS-Aufrufe für externe Sensoren usw. ebenfalls neu erstellen... DIES IST und WÄRE EIN ABSOLUTES NO GO !

Wenn ich mich darauf verlassen muss, dass eine solche Funktionalität (Backup/Restore) im produktiven AlltagsEinsatz auch das tut was sie soll, aber im Worst-Case-Fall versagt, dann kann ich diese Software und auch das Produkt RazBerry in Verbindung mit der ZWAY-Software niemandem auch nur ansatzweise empfehlen !

In diesem Fall würde das heißen, das alle frei zugänglichen (10) und unter Putz verbauten Zwave-Geräte (16+) (meist hinter einem Schalter) geöffnet, zurückgesetzt und neu includiert werden müssten!?

Dies habe ich jedoch nicht vor !!!!!

Ich hoffe, jemand kann mir da weiterhelfen

Grüße Simonchase
Raspberry PI 2, RazBerry

Location: Germany

ekkzk5f
Posts: 17
Joined: 20 Feb 2016 00:41

Re: Z-way-Backup -> replace RaZBerry -> Restore FAILED !!!

Post by ekkzk5f » 21 Mar 2017 11:22

Hallo,
nein - ich kann dir leider keinen konstruktiven Tip zu RaZberry & Z-Way geben :-(

Ich will eigentlich nur von dir wissen ob du mittlerweile eine Lösung gefunden hast, denn ich stehe vor einem ähnlichen Problem mit einem z-wave.me UZB1 Stick & OpenZWave.
Die bei OpenZWave mitgelieferte Demo-Applikation "Control Panel" (ozwcp) bietet auch gut sichtbar einen "Backup" Knopf, aber trotz intensiver Suche konnte ich bisher keine Möglichkeit zum Restore finden. (Der Knopf sollte wohl eher mit "Save" beschriftet sein).
Das Problem ist wohl die HomeID, die jeder Z-Wave Controller, also RaZberry und UZB1, bei der Herstellung weltweit eindeutig bekommt. Diese kann man so einfach nicht ändern - wenn das ginge wäre es ja auch eine Sicherheitslücke, da sich ein zusätzlich in der nähe aufgestellter neuer Z-Wave Controller wie deiner ausgeben könnte.

Eine im Design des Z-Wave Protokolls vorgesehen Möglichkeit wäre wohl gewesen neben dem primary Controller noch einen secondary Controller (SUC oder SIS) zu installieren. Dieser synchronisiert sich dann mit der Configuration immer live mit und ist auch in allen Nodes eingetragen. Falls der Primary Controller ausfällt sollte man dann per Befehl den Secondary Controller als Primary aktivieren können und alles müsste funktionieren wie vorher...
(sollte, müsste, wäre - viel Konjunktiv, denn ich hab da auch noch nicht getestet, und der redundante Controller muss natürlich vor dem Defekt installiert werden, also ist es für dein Netzwerk [und meines] zu spät)

Also:
Musstest du all deine Nodes neu Includieren oder hast du eine Lösung gefunden?

User avatar
Z-Wave Support
Posts: 194
Joined: 21 Oct 2016 15:49

Re: Z-way-Backup -> replace RaZBerry -> Restore FAILED !!!

Post by Z-Wave Support » 08 May 2017 10:32

Hallo,

hast du ein Backup vom Zway und vom Controller gemacht? oder nur eine Backup aus der Smarthome Ui heraus?

Das Backup aus der SmatHome Ui speichert nur die Einstellungen der Z-Way Software
Das Backup aus der Expert Ui (ControllerBAckup) sichert die Controllerdaten. Mit diesem lässt sich das Netzwerk auch wieder herstellen.

Viele Grüße
Z-Wave Support

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests