Проблема после обновления на 2.3.7

Данный раздел предназначен для русскоязычных пользователей. Если вы владеете английским, рекомендуем также просмотреть общую ветку обсуждений на английском.
Post Reply
DanilaMas
Posts: 22
Joined: 01 Aug 2015 07:27

Проблема после обновления на 2.3.7

Post by DanilaMas » 27 Mar 2018 10:05

Добрый день!

Обновился на 2.3.7 все отлично работало 2 дня.
Затем просто переключил на другую розетку, те был ненормальный шотдаун, последующий запуск и z-way сервер не стартует.
При попытке запустить вручную пишет:

pi@raspberrypi3:/opt/z-way-server $ ./z-way-server start
./z-way-server: error while loading shared libraries: libzcommons.so: cannot open shared object file: No such file or directory

Подскажите как вылечить?

Система стоит на Raspberry PI 3, модуль RazBerry, Z-way версии 2.3.7, Raspbian Jessei

Дополнение:
Есть папка, видимо бэкап перед установкой 2.3.7

А есть папка, как я понимаю рабочая сервера.

И она какая-то пустенькая....
Attachments
zway2.jpg
zway2.jpg (140.8 KiB) Viewed 768 times
Zway1.jpg
Zway1.jpg (111.64 KiB) Viewed 768 times
zway2.jpg
zway2.jpg (140.8 KiB) Viewed 769 times
zway2.jpg
zway2.jpg (140.8 KiB) Viewed 770 times
Last edited by DanilaMas on 27 Mar 2018 12:26, edited 1 time in total.

DanilaMas
Posts: 22
Joined: 01 Aug 2015 07:27

Re: Проблема после обновления на 2.3.7

Post by DanilaMas » 27 Mar 2018 12:04

Т.е. нет вообще папок Libs, Libzway, automation.
Подскажите, если не как исправить, а как откатиться на 2.3.6?

А если поверх снова установить 2.3.7 стандартной установкой, устройства мои сохраняться?

IgoriokLT
Posts: 69
Joined: 09 Oct 2016 15:24

Re: Проблема после обновления на 2.3.7

Post by IgoriokLT » 27 Mar 2018 20:14

чтобы откатиться на предыдущую версию, переименуйте папку с датой на z-way-server, а нынешнюю папку z-way server удалите.

User avatar
PoltoS
Posts: 4098
Joined: 26 Jan 2011 19:36

Re: Проблема после обновления на 2.3.7

Post by PoltoS » 28 Mar 2018 02:43

Забавный глюк файловой системы.... Проще скачать с сайта архив 2.3.7, распаковать его и перекинуть в текущую папку всё, чего не хватает.

DanilaMas
Posts: 22
Joined: 01 Aug 2015 07:27

Re: Проблема после обновления на 2.3.7

Post by DanilaMas » 28 Mar 2018 07:59

Да вот так получилось...
Попробовал я скачать архив и закинуть недостающие папки. Сервер запустился но совсем пустой, новый. Нет устройств и т.д.
В итоге я удалил текущую папку сервера, переименовал папку с крайней датой и запустился 2.3.6 с моими устройствами, все хорошо.
Попробовал снова апдейтить на 2.3.7 но штатный апдейтер не запускается из Управление-Обновление ПО. Как то другим способом можно запустить именно процесс обновления? (с сохранением базы устройств).

Подскажите (не нашел обсуждения), есть ли смысл менять платку на Razberry 2?

User avatar
PoltoS
Posts: 4098
Joined: 26 Jan 2011 19:36

Re: Проблема после обновления на 2.3.7

Post by PoltoS » 29 Mar 2018 05:26

запустите из шелла установщик - он определит, что уже есть текущая версия и обновит. Из веб-морды он же и запускается.

Дальность повысится точно с RaZberry 2. Если же у вас ещё на третьем поколении, то точно рекомендую обновится.

Post Reply