Schlage lock logging support still broken in v1.4

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
digistump
Posts: 4
Joined: 30 Mar 2013 04:36

Schlage lock logging support still broken in v1.4

Post by digistump » 27 Sep 2013 12:21

I was very excited about 1.4 and the promise of lock logging support, but Schlage locks still don't work right. The interview (even when forced) never returns that they are Lock Logging capable. And they seem to report the last used code as an alarm on 0x71.

This thread seems to imply that 0x71 should be supported in this version - but it is not: http://en.z-wave.me/content/proper-door-lock-support

I think the confusion is that 0x71 is alarm not lock logging and it looks like schlage uses the alarm command class to report the code entered.

From the log:

[2013-09-27 02:12:49.854] Node 5:0 CC Security: passing decrypted packet to application level: [ 71 05 10 02 ]
[2013-09-27 02:12:49.855] Node 5:0 CC Security: Got secure frame, but Command Class 0x71 isn't registered, instantiating it as not supported
[2013-09-27 02:12:49.856] Trying to create command for unknown CC 0x71
[2013-09-27 02:12:49.857] Command Class 0x71 is not supported (requested for node 5:0)


71 05 10 XX where XX refers to the number of the user code.


1) Any plans to support Alarm very soon? (we're so past our deadline we have to get Schlage support to work or use other controller hardware)

2) Is there any way with the current version to just bind to that signal? We are not using the UI and don't care about that - we just need a way to get that information out (besides parsing the logs). Preferably so it shows up when get updates like this: ZWaveAPI/Data/TIMESTAMP as a piece of data returned - but I'll take just about anything at this point.

Thanks!

User avatar
PoltoS
Posts: 4161
Joined: 26 Jan 2011 19:36

Indeed, there was a confusion

Post by PoltoS » 27 Sep 2013 12:21

Indeed, there was a confusion about 0x71 to be DoorLockLogging. I'm quite surprised to see that access notifications comes using Alarm and not via special DoorLockLogging CC. Pretty strang, taking into account, that Alarm CC is not well defined in Z-Wave.

We have plans to implement Alarm in next versions. This is in our to do list.

Umfortunatelly there are no way to trap command from unsupported command.

digistump
Posts: 4
Joined: 30 Mar 2013 04:36

Given that many things seem

Post by digistump » 27 Sep 2013 12:21

Given that many things seem unimplemented but come through the logs just fine - how about implementing a way to allow a hook/bind to unknown messages or all messages for a given class? - this would at least allow custom scripts to work regardless of official support.

User avatar
PoltoS
Posts: 4161
Joined: 26 Jan 2011 19:36

That's not a good idea, since

Post by PoltoS » 27 Sep 2013 12:21

That's not a good idea, since your next question would be - how to interpret these commands. And instead of working on implementations of other CCs, we will answer your questions ;)

These are next to implement in our todo (alphabetically):
Alarm
CRC16
ColorChooser
FirmwareUpgrade
MeterTable
Schedule

jensmoes
Posts: 57
Joined: 10 Jan 2015 21:48
Location: San Diego
Contact:

Re: Schlage lock logging support still broken in v1.4

Post by jensmoes » 01 Feb 2015 20:40

Is there any plan to support the Alarm CC in the Z-Way HA UI?
It would be nice if the UI updated its state when receiving alarms.
What happens now (2.0.1-rc11) is whenever the lock is accessed either from the inside handle, or outside with a code or key it will send the Access Control Alarm event with all the relevant information on what happened, but the Z-Way UI does not pick up this change so the widget state gets out of sync with the actual lock state

User avatar
PoltoS
Posts: 4161
Joined: 26 Jan 2011 19:36

Re: Schlage lock logging support still broken in v1.4

Post by PoltoS » 01 Feb 2015 22:57

Yes. It is supported in the backend, but is not in the frontend, so some tasks can be done via JS code.

The Alarm CC is one of the worst in Z-Wave and it is not easy to implement it in a good way. We are working on it.

cdogg76
Posts: 8
Joined: 28 Sep 2014 23:13

Re: Schlage lock logging support still broken in v1.4

Post by cdogg76 » 20 Sep 2017 23:19

Hello,

I'm also trying to get my Schlage lock to work properly. I sitll have the issue that jensmoes reports, where manual turning of the deadbolt will cause an Access Control alarm to be sent, but z-way doesn't update that state of the lock.

To work around this, I'm trying to do an if-then automation on the Access Control alarm to then issue a lock state Get, but I don't see the Access Control alarm (type 6) available in the HA UI. Only the other alarms are available (types 7, 8, 9), even though they fail to enable in the HA UI.

Is there some way that I can capture the Access Control notification to trigger an action?

Thanks!

cdogg76
Posts: 8
Joined: 28 Sep 2014 23:13

Re: Schlage lock logging support still broken in v1.4

Post by cdogg76 » 21 Sep 2017 22:10

Hello,

To be a little more clear, I expect to see the Access Control alarm (type 6) listed as a Binary Sensor, but it isn't listed. It only shows in the Control | Notifications of the Expert UI. There, it even shows the last time the event was triggered ("Manual Lock Operation"). I'd like to somehow set up a trigger on those manual lock operation events to run my HTTP device that will send a status Get on the lock to update the state.

Thanks!

Post Reply