Webif is switch off

Discussions about RaZberry - Z-Wave board for Raspberry computer
Mihadongle
Posts: 1
Joined: 20 Feb 2016 21:08

Webif is switch off

Post by Mihadongle » 20 Feb 2016 21:12

Hallo i have installed my razberry but when i get http://ip:8084 then say it to me Webif is switched off. You can switch it on from z-way or box shell.
How can i switch the webif on
Please help

rikym7
Posts: 1
Joined: 21 Feb 2016 04:00

Re: Webif is switch off

Post by rikym7 » 21 Feb 2016 04:06

I have exactly the same issue. I can access the URL at port 8083 and it allowed me to log in and I did set remote access to on for the device. When I access port 8084 I get the WebIF is not started error as well. I do see the port 8083 and 8084 open on the raspberry and :roll: obviously the error is coming from the web server. Is there a config file that needs to be updated?

Software info
Firmware version v2.2.1
UI version 1.3.0

Thanks!

joerod
Posts: 11
Joined: 26 Nov 2015 17:49

Re: Webif is switch off

Post by joerod » 22 Feb 2016 02:25

Same issue here after a firmware update.

wykz
Posts: 2
Joined: 05 Feb 2016 13:53

Re: Webif is switch off

Post by wykz » 22 Feb 2016 12:27

Same issue here after update to 2.2.1.

to get it up and running i go to the standard gui (port 8083 non expert ) and choose firmware update, after that webif will start up and port 8084 will work. However i need to do this every time i restart my pi so i just rollback to 2.2 (if webif is not running, i cant access my home )

User avatar
PoltoS
Posts: 4255
Joined: 26 Jan 2011 19:36

Re: Webif is switch off

Post by PoltoS » 23 Feb 2016 00:39

Please got to Z-Way->Setings->Management->Firmware upgrade. Once you close the popup, webif closes back. his was done for security reasons. You can also enable it using shell (in case of troubles with Z-Way):
/opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json

Write time to open 8084 in it (in seconds).

Sparkacus
Posts: 24
Joined: 26 Nov 2015 16:19

Re: Webif is switch off

Post by Sparkacus » 23 Feb 2016 12:10

Hey,

I also have this issue and the steps mentioned do not work for me.

The file /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json does not exist. Am I supposed to create it? If so, do I need to input some form of config etc?

I don't suppose you mind explaining what the security risk is?

Thanks

bogr
Posts: 168
Joined: 16 Nov 2015 22:46

Re: Webif is switch off

Post by bogr » 23 Feb 2016 12:38

I had the same problem. The upgrade process did not finish, at least the progress bar in the gui "hang", but it seemed that the upgrade actullay was ok since the server was up and running. When I checked for /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json it was missing, so I upgraded once again, and then the file was actually created. In other words try to upgrade once again to the "latest".

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Webif is switch off

Post by pz1 » 23 Feb 2016 12:57

FWIW: On my RaspiB+RaZberry v2.2.1 which has no problems with WebIF. the "8084" is also not available.

Sparkacus
Posts: 24
Joined: 26 Nov 2015 16:19

Re: Webif is switch off

Post by Sparkacus » 23 Feb 2016 22:26

bogr wrote:I had the same problem. The upgrade process did not finish, at least the progress bar in the gui "hang", but it seemed that the upgrade actullay was ok since the server was up and running. When I checked for /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json it was missing, so I upgraded once again, and then the file was actually created. In other words try to upgrade once again to the "latest".

I did want to upgrade again but I can't get access to the upgrade section due to this WebIf issue.

Is there a manual script to initiate an upgrade?

bogr
Posts: 168
Joined: 16 Nov 2015 22:46

Re: Webif is switch off

Post by bogr » 23 Feb 2016 23:16

Ah, ok, I actually managed to go through Expert UI -> Settings -> Management -> Firmware update -> Update to latest. But going via 8084 I got the Webif.

Post Reply