Webif is switch off

Discussions about RaZberry - Z-Wave board for Raspberry computer
bogr
Posts: 168
Joined: 16 Nov 2015 22:46

Re: Webif is switch off

Post by bogr » 23 Feb 2016 23:20

Try to create the file, as PoltoS suggested then, e.g.:

Code: Select all

pi@raspberrypi echo 900 > /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json

Sparkacus
Posts: 24
Joined: 26 Nov 2015 16:19

Re: Webif is switch off

Post by Sparkacus » 24 Feb 2016 00:53

bogr wrote:Try to create the file, as PoltoS suggested then, e.g.:

Code: Select all

pi@raspberrypi echo 900 > /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json

Perfect, yup that did the trick.

Thank you

gmccarthy
Posts: 1
Joined: 05 Mar 2016 16:49

Re: Webif is switch off

Post by gmccarthy » 05 Mar 2016 16:51

I'm getting this error as well after a failed upgrade. Unable to connect on port 8084.

I've tried creating the file above but it has no effect. Restarted the Pi and will getting the same error.

How do I resolve this error?

Error logs if it helps:
http://pastebin.com/EWZqU25X

Last error:
[2016-03-05 14:04:57.615] [core] Notification: critical (z-wave): Cannot start Z-Wave binding: Error: Bad data - communication failed


Update: Fixed the issue - reinstalled software. Not sure why it went wonky.
wget -q -O - http://razberry.z-wave.me/install | sudo bash

NanoBot
Posts: 8
Joined: 24 Mar 2016 23:03

Re: Webif is switch off

Post by NanoBot » 25 Mar 2016 00:09

Would someone please help me with pulling up the page that has the Expert UI settings?
I am having the same problem as others regarding the Webif upgrade... thank you

How do I do this?
Expert UI -> Settings -> Management -> Firmware update -> Update to latest
Last edited by NanoBot on 25 Mar 2016 01:23, edited 2 times in total.

NanoBot
Posts: 8
Joined: 24 Mar 2016 23:03

Re: Webif is switch off

Post by NanoBot » 25 Mar 2016 00:39

PoltoS wrote:Please got to Z-Way->Setings->Management->Firmware upgrade. Once you close the popup, webif closes back. his was done for security reasons. You can also enable it using shell (in case of troubles with Z-Way):
/opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json

Write time to open 8084 in it (in seconds).
When I enter the above the following is what I get:

pi@raspberrypi:~ $ /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json
bash: /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json: No such file or directory

Would you please let me know what I'm doing wrong?
I am trying to correct the issue with following error:

" Webif is switched off. You can switch it on from Z-Way UI or box shell"

Thank you.[/quote]

User avatar
PoltoS
Posts: 4224
Joined: 26 Jan 2011 19:36

Re: Webif is switch off

Post by PoltoS » 27 Mar 2016 02:41

It should be

Code: Select all

pi@raspberrypi echo 900 > /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json

NanoBot
Posts: 8
Joined: 24 Mar 2016 23:03

Re: Webif is switch off

Post by NanoBot » 28 Mar 2016 20:39

PoltoS;
When I enter the command you sent below; i receive a "Permission denied" error... see below... please let me know what I'm doing wrong... thank you...

pi@raspberrypi echo 900 > /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json

bash: /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json: Permission denied

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Webif is switch off

Post by pz1 » 28 Mar 2016 20:48

Did you try with sudo?

Code: Select all

sudo echo 900 > /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json

NanoBot
Posts: 8
Joined: 24 Mar 2016 23:03

Re: Webif is switch off

Post by NanoBot » 30 Mar 2016 01:41

Yes, I tried it with psudo as follows ... same results... Permission denied.... see below

pi@raspberrypi:~ $ sudo echo 900 > /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json

bash: /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json: Permission denied

bogr
Posts: 168
Joined: 16 Nov 2015 22:46

Re: Webif is switch off

Post by bogr » 30 Mar 2016 23:12

That's really strange, but maybe the permissions got screwed up somehow. Check the permissions:

Code: Select all

ls -l /opt/z-way-server/automation/storage/8084AccessTimeout-6b497208061ec7faae003cdd7f9a035e.json
That should show you that at least the user (root) has +w.

Post Reply