Set Parameters from device

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
Wikibear
Posts: 88
Joined: 01 Jul 2016 14:10

Set Parameters from device

Post by Wikibear » 03 Jul 2016 15:39

Hello together,

i use a Fibaro Motion Sensor with 2.7 Firmware. The manual say that define parameters are available:

http://manuals.fibaro.com/motion-sensor/

My goal is to increase the illuminating sensor with sending data. Default is 0 no sending data. Thats bad.

I found a link in web that makes Temp more times:

wget http://192.168.10.xxx:8083/ZWaveAPI/Run ... (64,600,2)

So i dont know what this parameters mean!

How can i set parameters for illumination as fibaro say in manual?
Greatings from the noob

Wikibear
Posts: 88
Joined: 01 Jul 2016 14:10

Re: Set Parameters from device

Post by Wikibear » 03 Jul 2016 23:00

Found solution! That's totally hard for a noob like me. So i understand after long testing reading and compare my knowings.

This webpage here:
http://manuals.fibaro.com/motion-sensor/
has a list of all advanced parameters. The hint is here that 1,2,3 counting are not a normal counting this are for parameters. So my needings where here 40. You can set this via configuration of device in expert ui or you can do this via API:

http://rasip:8083/ZWaveAPI/Run/devices[ ... alue,byte)

I do it via browser.

http://rasip:8083/ZWaveAPI/Run/devices[ ... et(40,5,2)

And now i get every time lux change an update with fibaro multi sensor. You can/must do the same with temp.
Greatings from the noob

User avatar
PoltoS
Posts: 5093
Joined: 26 Jan 2011 19:36

Re: Set Parameters from device

Post by PoltoS » 31 Jul 2016 01:38

Our doc describes pretty well these command. Indeed you can use these API calls to set params wrongly descirbed in device description. You can also use Expert Commands tab to send fill user friendly form to send same commands

Post Reply