Zway Exclusion works - Inclusion not

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
Posts: 5
Joined: 29 Apr 2017 11:42

Zway Exclusion works - Inclusion not

Post by Sidekickat » 29 Apr 2017 12:01

Hi there! I am new to the Raspberry/Razberry/Z-Wave world and it's driving me nuts :?

I use a Raspberry PI 3 B with Razberry2 ZMEERAZ2 and installed Z-Way on Raspian. In Z-Way I want to add a Fibaro Roller Shutter 2 FGR-222 (EU). I start the exclusion and push the B-Button on the Fibaro 3 times very fast and Z-Way shows me a success message. After that I start the inclusion and hit the B-Button 3 times very fast again but the inclusion runs in a timeout ('inclusion takes a long time to start up').

I did a factory reset on the Fibaro and tried a second Fibaro Roller Shutter 2 but it ended up with the same behaviour.
Then I installed Z-Way again (this time I used the SD-card image) and again: The exclusion works but the inclusion not.

Is it likely that I have a bad Razberry-Module and a replacement unit should work?
Thanks for any suggestion before I have to send the device back!

User avatar
Posts: 4683
Joined: 26 Jan 2011 19:36

Re: Zway Exclusion works - Inclusion not

Post by PoltoS » 30 May 2017 20:15

Inclusion log is required.

If inclusion doesn't work, but exclusion do, means you don't initiate inclusion on the device (wakeup sequence is used) or RaZberry is not primary

Posts: 2
Joined: 30 Dec 2017 01:06

Re: Zway Exclusion works - Inclusion not

Post by theforce » 30 Dec 2017 01:23

I have the same problem. Have tried almost everything to make inclusions work. I have an old Razberry in an old Raspberry Pi model B. The plan is to get rid of those and create a new network from scratch with a Raspberry Pi 3 and the Razberry2. I switched out the Razberry2 to the old Razberry on the Raspberry pi 3 and then inclusion worked fine (as expected) so I hope it's not a hardware related issue... I noticed the Razberry2 has a small pink patch of paint near the GPIO-connectors. Hope that is not a sign of a malfunctioning controller board that someone accidentally cleared as functioning.

If I have reset and/or excluded a device from the old controller, shouldn't it be possible to include it to a new controller, i.e. to the Razberry2? I have shut off the old Razberry but not my devices which I plan to exclude and include one at a time to the Razberry2. I tried joining the current network and make the new controller primary but it doesn't seem to work. Also, I don't like to use the old network with a lot of gaps in the device/node ids.. it annoys me very much, I want all the device ids in order starting with #2 (the zway is #1) with no gaps.

Posts: 1
Joined: 23 Jan 2018 20:28

Re: Zway Exclusion works - Inclusion not

Post by rakesh20 » 23 Jan 2018 20:56

thanks .. its working for me

Post Reply