Full interviewed sensative strip disappeared

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
marco
Posts: 58
Joined: 03 Dec 2015 19:50

Full interviewed sensative strip disappeared

Post by marco » 04 Sep 2017 09:37

Hi all,
This is to highlight a new issue on zway system.
A windows/doors sensative strip suddenly started to have an unpredictable behavior: it started to report door as open and closed alternatively. First I excluded it from the rules. Then I perform a call for nif and a reinterview. Now the strip is 100% interviewed and recognized but it is still disappeared from the UI.
What I state is that in the Configjson file there is a strange thing:
The strip seems to be

Code: Select all

        "ZWayVDev_zway_58-0-48-1": {
            "deviceType": "sensorBinary",
            "metrics": {
                "probeTitle": "General purpose",
                "scaleTitle": "",
                "icon": "motion",
                "level": "off",
                "title": "Living Balc (58.0.48.1)",
                "modificationTime": 1496834102,
                "lastLevel": "off"
            },
            "location": 1,
            "tags": [],
            "permanently_hidden": false,
            "creationTime": 1473682586,
            "h": 27493264,
            "hasHistory": false,
            "visibility": true
        },
        "ZWayVDev_zway_58-0-128": {
            "deviceType": "battery",
            "metrics": {
                "probeTitle": "Battery",
                "scaleTitle": "%",
                "level": 100,
                "icon": "battery",
                "title": "Battery (58.0)",
                "modificationTime": 1473835095,
                "lastLevel": 100
            },
            "location": 0,
            "tags": [],
            "permanently_hidden": false,
            "creationTime": 1473682587,
            "customIcons": {}
        },
        "ZWayVDev_zway_58-0-113-7-4-A": {
            "deviceType": "sensorBinary",
            "metrics": {
                "icon": "smoke",
                "level": "off",
                "title": "Living Balc (58.0.113.7.4)"
            },
            "location": 1,
            "tags": [],
            "permanently_hidden": false,
            "creationTime": 1473682587,
            "h": -1299645776,
            "hasHistory": false,
            "visibility": true
        },
        "ZWayVDev_zway_58-0-113-6-Door-A": {
            "deviceType": "sensorBinary",
            "metrics": {
                "icon": "door",
                "level": "off",
                "title": "Living Balc (58.0.113.6.Door)",
                "modificationTime": 1502576797,
                "lastLevel": "off"
            },
            "location": 1,
            "tags": [],
            "permanently_hidden": false,
            "creationTime": 1473682587,
            "customIcons": {},
            "h": 160550491,
            "hasHistory": false,
            "visibility": true
        },
And what is strange is the following

Code: Select all

        "ZWayVDev_zway_58-0-38": {
            "deviceType": "switchMultilevel",
            "metrics": {
                "icon": "blinds",
                "title": "Blind (58.0)",
                "level": 0,
                "modificationTime": 1473533671,
                "lastLevel": 0
            },
            "location": 0,
            "tags": [],
            "permanently_hidden": false,
            "creationTime": 1473533178,
            "h": 2046953677,
            "hasHistory": false,
            "visibility": true
        },
        "ZWayVDev_zway_58-0-37": {
            "deviceType": "switchBinary",
            "metrics": {
                "icon": "switch",
                "title": "Switch (58.0)",
                "level": "on",
                "modificationTime": 1473533178,
                "lastLevel": "on"
            },
            "location": 0,
            "tags": [],
            "permanently_hidden": false,
            "creationTime": 1473533178,
            "h": 2046953676,
            "hasHistory": false,
            "visibility": true
        },
It seems that this last part has some bad duplicate.
To call back the strip in the UI, can I delete this second part from the file?
Otherwise, how can I do without reinstall strip again (so removing it from the installation location) ?
Last edited by marco on 05 Oct 2017 23:15, edited 1 time in total.
Marco

marco
Posts: 58
Joined: 03 Dec 2015 19:50

Re: Full interviewed sensative strip disappeared

Post by marco » 05 Oct 2017 13:58

Hi, the topic is still open for me even if time is gone.
Any way a new important question came to me: is there another file that zway uses for managing devices configuration?
Marco

marco
Posts: 58
Joined: 03 Dec 2015 19:50

Re: Full interviewed sensative strip disappeared

Post by marco » 05 Oct 2017 23:49

Ok, waiting for some replies, we've tried to attempt something.
Let me do a short recap. Sensative strip id 58 was already included into the system and start to have a bizarre behaviour. After a full reinterview it is disappeard from the UI and the config-xxx.json file reports it as previous reported.
We've tried to include a new strip. It has been included with id 113; it has been full interviewed but also this is not present in the UI. In the config-xxx.json it is reported only as "deviceType": "battery". Bad thing.
Reading config-xxx.json file and comparing the code for a working strip with that id 58, we've individuate some differences. So we've tried to manually modify config-xxx.json file in order to have the description for id 58 similar to the one of a working strip. No effect.
Looking at namespace file, we can state that both id 58 and 113 are present as "device_all" and "battery" but not as "sensorbinary" like for the other working strips.

How is it possible to solve this?

Is it possible to manually modify config-xx.json file as we tried?

If yes, how can we do?

After the modification, do we need to do something else to let modifies working?
Marco

User avatar
PoltoS
Posts: 4029
Joined: 26 Jan 2011 19:36

Re: Full interviewed sensative strip disappeared

Post by PoltoS » 06 Oct 2017 00:42

config-xxx.json is an internal Z-Way file it is not to be modified.

Provo
Posts: 112
Joined: 19 Oct 2016 19:54

Re: Full interviewed sensative strip disappeared

Post by Provo » 06 Oct 2017 06:57

Have you tried to exclude the device and reinclude it?

marco
Posts: 58
Joined: 03 Dec 2015 19:50

Re: Full interviewed sensative strip disappeared

Post by marco » 29 Nov 2017 13:09

of course I tried to do that. It seems we have similar problem also with aeotec multisensors
Marco

vlad
Posts: 32
Joined: 19 Oct 2016 04:58

Re: Full interviewed sensative strip disappeared

Post by vlad » 29 Nov 2017 19:40

What is your version (server and razberry board firmware)?

Post Reply