Server is constantly crashing

Discussions about RaZberry - Z-Wave board for Raspberry computer
kpanchen
Posts: 17
Joined: 08 Sep 2017 05:27

Server is constantly crashing

Post by kpanchen » 15 Oct 2017 00:43

Wonder what is others experience and what are you doing to prevent this. My server on RaspberryPi 3 is constantly crashing, 2.3.5 was crashing about every single day but new one (2.3.6) is start crashing just randomly about every hour which is off course killer for any automation. Raspberry itself is running fine but z-way is just and had to restart it.

Went through some forum posts, as suggested turned off logging (set to 4), removed json notification file, still crashing. Is it safe to kill some other json files, the biggest I have now is like 600k.

What's your experience?

Thanks K.

User avatar
PoltoS
Posts: 3920
Joined: 26 Jan 2011 19:36

Re: Server is constantly crashing

Post by PoltoS » 15 Oct 2017 23:48

We have seen sporadic reports about Z-Way crashing. Unfortunatelly most of reports lacks of information.

Could you please list all modules you have in your automation and may be run it through GDB to let us check once it crashes via remote access. Is it something possible?

kpanchen
Posts: 17
Joined: 08 Sep 2017 05:27

Re: Server is constantly crashing

Post by kpanchen » 15 Oct 2017 23:52

Thanks, Sergey, I'm doing some testing now, trying to capture a log when it crashes, will provide it. As usual since I post this and enable logging again (log file is about 30 megs now) server is not crashing.

kpanchen
Posts: 17
Joined: 08 Sep 2017 05:27

Re: Server is constantly crashing

Post by kpanchen » 16 Oct 2017 09:32

Here's the log extract til the end, I don't see anything special there, it just stooped. I have 10 devices and some App configured but nothing special, the biggest is the Security Module and I think that's the indirect culprit, it is somehow related to notifications it's trying to send. I've configured E-mail ones which works fine and Phone ones which don't, notifications never showed up on the phone. Any suggestions what to do next?

Thanks!
Attachments
z-way-server_cut.zip
(2.91 KiB) Downloaded 15 times

paaland
Posts: 16
Joined: 08 Jun 2017 09:24
Location: Norway

Re: Server is constantly crashing

Post by paaland » 16 Oct 2017 13:38

I have the same issue. Running v2.3.6. I've created a script that checks every fire minutes for z-way-server process and starts it if no such process is running. This is the restart log:

Restarting z-way-server: Thu 28 Sep 08:55:01 CEST 2017
Restarting z-way-server: Mon 2 Oct 09:05:01 CEST 2017
Restarting z-way-server: Thu 5 Oct 08:30:01 CEST 2017
Restarting z-way-server: Fri 6 Oct 15:30:05 CEST 2017
Restarting z-way-server: Sat 14 Oct 16:30:01 CEST 2017

As you can see it varies much how long it's running before it crashes. There are nothing (no errors) in the log when it crashes. Just seems the process dies (or is killed).

diemue
Posts: 24
Joined: 09 Sep 2015 12:40

Re: Server is constantly crashing

Post by diemue » 16 Oct 2017 16:56

I have the same problem. v2.3.6 stops running after 2 - 3 days. @paaland: could you provide me your restart script ?

micky1500
Posts: 41
Joined: 07 Feb 2016 16:29

Re: Server is constantly crashing

Post by micky1500 » 16 Oct 2017 20:33

Monit works for me.
Nothing worse than waking up in the morning with a dead z-way.
No lights and no heating..

Isaksson gave a good explanation.
viewtopic.php?f=3419&t=24730&p=68247&hi ... art#p68247

kpanchen
Posts: 17
Joined: 08 Sep 2017 05:27

Re: Server is constantly crashing

Post by kpanchen » 17 Oct 2017 07:34

micky1500 wrote:
16 Oct 2017 20:33
Monit works for me.
Nothing worse than waking up in the morning with a dead z-way.
No lights and no heating..

Isaksson gave a good explanation.
viewtopic.php?f=3419&t=24730&p=68247&hi ... art#p68247
Thanks Micky, just installed monit, seems like that's not a solution but at least a workaround which let me to see when server is really crashing and restart it. I hope developers can find an ultimate solution.

K.

User avatar
PoltoS
Posts: 3920
Joined: 26 Jan 2011 19:36

Re: Server is constantly crashing

Post by PoltoS » 19 Oct 2017 08:30

Hello!

This is very good that you all see similar problems. Could all of you provide some debug info. Better to run it in gdb ignoring two first SIGILL.

Once it crashes, please do "bt" and "info thr"

As I know, we know only one reason to crash - some bug in sockets. We are hunting it. Do you all use sockets module (like Sonos app)?

kpanchen
Posts: 17
Joined: 08 Sep 2017 05:27

Re: Server is constantly crashing

Post by kpanchen » 20 Oct 2017 09:12

PoltoS wrote:
19 Oct 2017 08:30
Hello!

This is very good that you all see similar problems. Could all of you provide some debug info. Better to run it in gdb ignoring two first SIGILL.

Once it crashes, please do "bt" and "info thr"

As I know, we know only one reason to crash - some bug in sockets. We are hunting it. Do you all use sockets module (like Sonos app)?
Willing to help, do you have somewhere clear instructions on what to do and what kind of logs you need, I'm IT but not very proficient with nix systems and just playing with z-way for a few months.

I don't have any such modules, just if-then's, conditions and polling. Would be great if you know a way to list all the modules without the screenshot of Apps page.

K.

Post Reply