Replacing faulty RaZberry hardware

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
siulung
Posts: 3
Joined: 07 Aug 2017 05:37

Replacing faulty RaZberry hardware

Post by siulung » 09 Apr 2018 09:15

Hi,

A few days ago my z-wave setup suddenly stopped working:
[2018-04-04 20:20:17.319] [zway] Adding job: Get controller info and supported function classes
[2018-04-04 20:20:17.326] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2018-04-04 20:20:17.529] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2018-04-04 20:20:17.530] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2018-04-04 20:20:17.731] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2018-04-04 20:20:17.731] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2018-04-04 20:20:17.933] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2018-04-04 20:20:17.933] [W] [zway] Job 0x07 (Get controller info and supported function classes) dropped: too many resends
[2018-04-04 20:20:17.933] [D] [zway] Job 0x07 (Get controller info and supported function classes): fail


I suspected the RaZberry module is faulty, so I ordered a new one. Today it arrived and z-way-server starts up without error, except that all devices are gone (while the json configs files still refer to those devices).

My z-way installation is still intact, so I suppose I still have the cryptographic keys to talk to the devices despite new hardware? If so, what's wrong?

Or do I have to pair all the devices again?

enbemokel
Posts: 163
Joined: 08 Aug 2016 17:36

Re: Replacing faulty RaZberry hardware

Post by enbemokel » 09 Apr 2018 11:50

Hi, you just have to use your backup files from the expert menu.

siulung
Posts: 3
Joined: 07 Aug 2017 05:37

Re: Replacing faulty RaZberry hardware

Post by siulung » 10 Apr 2018 01:47

@enbemokel my old RaZberry is not working and so I can no longer take a backup with the devices intact, right? And obviously I forgot to take a backup while it was working.

Note that while the automation/storage/configjson-xxxxxxxxxxxxxxxxxxxxxxx.json is still intact, config/zddx/xxxxxxxx-DevicesData.xml is already truncated to only having device #1. Dropping the old xml into place doesn't seem to work with the new RaZberry card.

enbemokel
Posts: 163
Joined: 08 Aug 2016 17:36

Re: Replacing faulty RaZberry hardware

Post by enbemokel » 10 Apr 2018 13:42

Ah, don´t know that you didn´t made a backup. Sometimes there might be an old backup available.

Post Reply