Page 1 of 1

No access to IP:8083 page

Posted: 04 May 2018 21:29
by testerbb
Hi everybody

I'm new here, because i started to play around with my raspberry and the option of zwave is very interesting.
Nevertheless, i followed the installation procedure, all works fine.
By accessing the page the link with the IP is visible, ok.
By clicking and going to the page: IP:8083 an error message is displayed: unable to connect. It seems the server is not running, but it does. Checked with z-way server status. even with localhost:8083 the same error is shown.
Do i have to configure my router or where could be the error?

Thanks in advance for your help

Re: No access to IP:8083 page

Posted: 05 May 2018 05:25
by adamjarema
Can you check any log pages? I'm having this issue too. What I am finding is that the z-way server process is not actually starting. If you look at: systemctl status z-way-server it should tell you if it is running or has exited.

Re: No access to IP:8083 page

Posted: 05 May 2018 10:12
by testerbb
In my eyes its running.. isn't it?

pi@raspberrypi:~ $ systemctl status z-way-server
‚óŹ z-way-server.service - LSB: RaZberry Z-Wave service
Loaded: loaded (/etc/init.d/z-way-server; generated; vendor preset: enabled)
Active: active (exited) since Wed 2018-05-02 21:00:38 CEST; 2 days ago
Docs: man:systemd-sysv-generator(8)
Process: 318 ExecStart=/etc/init.d/z-way-server start (code=exited, status=0/S
CGroup: /system.slice/z-way-server.service

May 02 21:00:38 raspberrypi systemd[1]: Starting LSB: RaZberry Z-Wave service...
May 02 21:00:38 raspberrypi z-way-server[318]: Starting z-way-server: done.
May 02 21:00:38 raspberrypi systemd[1]: Started LSB: RaZberry Z-Wave service.

Re: No access to IP:8083 page

Posted: 08 May 2018 06:15
by adamjarema
No, it has exited. Seems you and I have the same problem. Interesting.

Re: No access to IP:8083 page

Posted: 09 May 2018 19:33
by Brekne
Backend server error. When will this problem be solved. Have no remote access to my 2 razberries. Frustrated

Re: No access to IP:8083 page

Posted: 09 May 2018 21:34
by testerbb
Does anybody have any ideas to solve the problem?

Re: No access to IP:8083 page

Posted: 11 May 2018 03:05
by adamjarema
My problem with this is that I'm not getting any logs from the z-way server. I think it has something to do with one of the packages being updated that the server depends on, but that's just a hunch.

Re: No access to IP:8083 page

Posted: 07 Jun 2018 10:09
by mtylerb
I know it's been almost a month, but I thought you might be interested in the solution I found with the help of the github issues. I'm copying this directly from the Raspbian forum where I had previously asked for help:

Well, answered my own question after having a eureka "search idea" moment. I found a github issue with a specific response that seems to have solve the problem. So for others:

Code: Select all

$ cd \tmp
$ wget
$ sudo dpkg -x libssl1.0.0_1.0.1t-1+deb8u8_armhf.deb .
$ sudo mv usr/lib/arm-linux-gnueabihf/lib* /opt/z-way-server/libs/
Please keep in mind that the filename had changed from the original response in the github issue. I had to traverse the URL directories to discover that libssl1.0.0_1.0.1t-1+deb8u7_armhf.deb had become libssl1.0.0_1.0.1t-1+deb8u8_armhf.deb. So if you get a 404 error with the wget command, you may need to do something similar. The problem occurs due to the change in libssl from 1.0.0 to 1.0.2, so you're looking specifically for libssl1.0.0.

With that in, my problem seems to be solved for the moment. They're planning on updating to stretch, but they seem to be on the slower side. At least it runs.