Failed to upgrade to version 3

Discussions about RaZberry - Z-Wave board for Raspberry computer
murraymint
Posts: 1
Joined: 13 Jan 2018 21:33

Failed to upgrade to version 3

Post by murraymint » 01 Sep 2019 13:29

Hi Guys,

I have just tried following the instructions https://z-wave.me/z-way-v3-0-0/ to upgrade my Z-wave me to version, all gose fine until the point after I update the sources.list.d/z-wave-me.list. when i run the command sudo apt-get update I revcieve the following error.

pi@ZWAVEME-PI:~ $ sudo apt-get update
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?

If I try to web browse to "https://repo.z-wave.me/z-way/raspbian stretch main contrib" i receive a !requested URL" was not found.

Can anyone help?

Thanks.

User avatar
PoltoS
Posts: 4978
Joined: 26 Jan 2011 19:36

Re: Failed to upgrade to version 3

Post by PoltoS » 01 Sep 2019 18:47

Please follow the standard way of installation via a command described here https://z-wave.me/z-way/download-z-way/:

Code: Select all

wget -q -O - https://storage.z-wave.me/RaspbianInstall | sudo bash

Josjr
Posts: 7
Joined: 02 Sep 2019 22:38

Re: Failed to upgrade to version 3

Post by Josjr » 02 Sep 2019 22:54

I also have a lot of issues since I started upgrading to v3.
- Firmware upgrade of Razberry doesn't work
- Can't include devices anymore to my Z-wave gateway
- All kind of strange errors on the UI

Executing apt update
When running the given bash command on the website I get this during update.

Code: Select all

All packages are up to date.
W: Skipping acquire of configured file 'contrib/binary-armhf/Packages' as repository 'https://repo.z-wave.me/z-way/raspbian stretch InRelease' doesn't have the component 'contrib' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'contrib/i18n/Translation-en_GB' as repository 'https://repo.z-wave.me/z-way/raspbian stretch InRelease' doesn't have the component 'contrib' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'contrib/i18n/Translation-en' as repository 'https://repo.z-wave.me/z-way/raspbian stretch InRelease' doesn't have the component 'contrib' (component misspelt in sources.list?)
Firmware upgrade
Because installing the firmware from the tool didn't work I tried the one written over on the link below. But the files "bootloader.bin" and "firmware_file.bin" I don't have and I can't find anywhere. So when searching further I found via "/var/log/z-way-server.log" a file on the server of Z-wave. This works but had no effect on making my Z-Wave devices work again.
https://z-wave.me/zmeserialupdater-manual/
https://service.z-wave.me/expertui/uzb/ ... _05_04.bin

Code: Select all

ZMESerialUpdater serialapi_uzbupdate -b bootloader.bin -f firmware_file.bin -d /dev/ttyAMA0
Images
Image
Image
Image
Image
Image
Image
Image

Side note
This is a RPI 3 which also contains the following Mono version.
Mono JIT compiler version 6.0.0.327 (tarball Thu Aug 29 21:36:32 UTC 2019)

Josjr
Posts: 7
Joined: 02 Sep 2019 22:38

Re: Failed to upgrade to version 3

Post by Josjr » 02 Sep 2019 23:02

When executing "Call for NIF" in Export Mode to my Razberry I get this

Code: Select all

[2019-09-02 21:00:19.130] [I] [zway] Adding job: Request NIF from a node
[2019-09-02 21:00:19.136] [D] [zway] SENDING: ( 01 04 00 60 01 9A )
[2019-09-02 21:00:19.138] [D] [zway] RECEIVED ACK
[2019-09-02 21:00:19.143] [D] [zway] RECEIVED: ( 01 04 01 60 01 9B )
[2019-09-02 21:00:19.143] [D] [zway] SENT ACK
[2019-09-02 21:00:19.143] [I] [zway] Job 0x60 (Request NIF from a node): Request for node 1 information frame sent
[2019-09-02 21:00:23.415] [D] [zway] RECEIVED: ( 01 06 00 49 81 00 00 31 )
[2019-09-02 21:00:23.415] [D] [zway] SENT ACK
[2019-09-02 21:00:23.415] [I] [zway] Node info request failed
[2019-09-02 21:00:23.415] [I] [zway] Job 0x60 (Request NIF from a node): Node info request failed
[2019-09-02 21:00:23.415] [D] [zway] SENDING: ( 01 04 00 60 01 9A )
[2019-09-02 21:00:23.422] [D] [zway] RECEIVED ACK
[2019-09-02 21:00:23.423] [D] [zway] RECEIVED: ( 01 04 01 60 01 9B )
[2019-09-02 21:00:23.423] [D] [zway] SENT ACK
[2019-09-02 21:00:23.423] [I] [zway] Job 0x60 (Request NIF from a node): Request for node 1 information frame sent
[2019-09-02 21:00:27.813] [D] [zway] RECEIVED: ( 01 06 00 49 81 00 00 31 )
[2019-09-02 21:00:27.813] [D] [zway] SENT ACK
[2019-09-02 21:00:27.813] [I] [zway] Node info request failed
[2019-09-02 21:00:27.813] [I] [zway] Job 0x60 (Request NIF from a node): Node info request failed
[2019-09-02 21:00:27.813] [D] [zway] SENDING: ( 01 04 00 60 01 9A )
[2019-09-02 21:00:27.817] [D] [zway] RECEIVED ACK
[2019-09-02 21:00:27.820] [D] [zway] RECEIVED: ( 01 04 01 60 01 9B )
[2019-09-02 21:00:27.820] [D] [zway] SENT ACK
[2019-09-02 21:00:27.820] [I] [zway] Job 0x60 (Request NIF from a node): Request for node 1 information frame sent
[2019-09-02 21:00:32.451] [D] [zway] RECEIVED: ( 01 06 00 49 81 00 00 31 )
[2019-09-02 21:00:32.451] [D] [zway] SENT ACK
[2019-09-02 21:00:32.451] [I] [zway] Node info request failed
[2019-09-02 21:00:32.451] [I] [zway] Job 0x60 (Request NIF from a node): Node info request failed
[2019-09-02 21:00:32.451] [I] [zway] Job 0x60 (Request NIF from a node): Removing job due to too much retransmitions
[2019-09-02 21:00:32.452] [I] [zway] Adding job: Check if node is failed
[2019-09-02 21:00:32.452] [D] [zway] Job 0x60 (Request NIF from a node): fail
[2019-09-02 21:00:32.452] [I] [zway] Removing job: Request NIF from a node
[2019-09-02 21:00:32.452] [D] [zway] SENDING: ( 01 04 00 62 01 98 )
[2019-09-02 21:00:32.454] [D] [zway] RECEIVED ACK
[2019-09-02 21:00:32.454] [D] [zway] RECEIVED: ( 01 04 01 62 01 99 )
[2019-09-02 21:00:32.454] [D] [zway] SENT ACK
[2019-09-02 21:00:32.454] [D] [zway] SETDATA devices.1.data.isFailed = True
[2019-09-02 21:00:32.454] [I] [zway] Job 0x62 (Check if node is failed): Node 1 is failed
[2019-09-02 21:00:32.454] [D] [zway] Job 0x62 (Check if node is failed): success
[2019-09-02 21:00:32.454] [D] [zway] SETDATA devices.1.data.failureCount = 1 (0x00000001)
[2019-09-02 21:00:32.455] [D] [zway] SETDATA devices.1.data.lastSendInternal = **********
[2019-09-02 21:00:32.455] [I] [zway] Removing job: Check if node is failed

platypus
Posts: 16
Joined: 28 Apr 2019 16:32

Re: Failed to upgrade to version 3

Post by platypus » 04 Sep 2019 18:35

I tried to update to 3.0.0 and really regret it. It made lots of problems. The update finished with success, but even after waiting a few more minutes, clearing browser cache and logging out and in again and reloading the page it still showed version 2.3.8. I started the update again but even after more than 30 minutes it was stuck at status “starting update”. I finally closed the update window, waited for a while, restarted the pi and surprise… z-way did not launch anymore. After restoring an image of the whole SD card I had to learn the hard way, that linux’s dd command, like recommended for backup in countless post around the internet, does not provide consistent snapshots. I had to start from zero with a fresh image of raspbian stretch and was able to install 3.0.0 successfully.
Then I tried to update the razberry firmware to 5.36 and the update finished successfully. I clicked on ok, waited for a while but no controller information showed up. I restarted z-way server and now it can’t communicate with the razberry board anymore. The server log didn’t show any error during firmware update. What a mess, according to the manual the board has to be replaced when both LEDs are always on.

User avatar
PoltoS
Posts: 4978
Joined: 26 Jan 2011 19:36

Re: Failed to upgrade to version 3

Post by PoltoS » 05 Sep 2019 23:05

@platypus Does your board show both LEDs? In that case please replace it. Sorry for this.

User avatar
PoltoS
Posts: 4978
Joined: 26 Jan 2011 19:36

Re: Failed to upgrade to version 3

Post by PoltoS » 05 Sep 2019 23:05

@platypus Does your board show both LEDs? In that case please replace it. Sorry for this.

User avatar
PoltoS
Posts: 4978
Joined: 26 Jan 2011 19:36

Re: Failed to upgrade to version 3

Post by PoltoS » 05 Sep 2019 23:14

@Josjr Files ara available from our web site. Description is available here https://z-wave.me/zmeserialupdater-manual/

And it looks like your Mono is occupying the same 8084 port as our update service. But don't mind, you can always use apt-get to upgrade Z-Way.

platypus
Posts: 16
Joined: 28 Apr 2019 16:32

Re: Failed to upgrade to version 3

Post by platypus » 07 Sep 2019 21:27

PoltoS wrote:
05 Sep 2019 23:05
@platypus Does your board show both LEDs? In that case please replace it. Sorry for this.
I already received a new RaZberry board. It was exchanched very quickly and convienient. The new one is working and already has serial api version 5.37.

Josjr
Posts: 7
Joined: 02 Sep 2019 22:38

Re: Failed to upgrade to version 3

Post by Josjr » 13 Sep 2019 09:04

@PoltoS

The first upgrade command returns this:
./ZMESerialUpdater serialapi_uzbupdate -d /dev/ttyAMA0 -b bootloader_Razberry_from_05_04_to_8aaa_2MB.bin -f UPD_FIRMWARE_Razberry500_from_05_04_to_05_07.bin

Device ready in:3.04094195366 seconds
BOOTLODER
Openning port .............................. OK
Writing NVM data .............................. OK
Waiting for Boot reflashing .............................. OK
-->
Device ready in:1.05003499985 seconds
FIRMWARE
Openning port .............................. OK
Writing NVM data .............................. FAILED

Error 0 returned 1 for ACK

Writing NVM data .............................. FAILED

Error 1 Unknown exception:Can't write NVM data! at=48800

The second one did go ok
./ZMESerialUpdater serialapi_uzbupdate -d /dev/ttyAMA0 -f UPD_FIRMWARE_Razberry_from__05_07__to__05_17.bin

-->
Device ready in:3.04455184937 seconds
FIRMWARE
Openning port .............................. OK
Writing NVM data .............................. OK
Setting update flag .............................. OK
Reseting chip .............................. OK
Waiting for FW reflashing .............................. OK
-->
Device ready in:1.04048395157 seconds
FULL INFO
Openning port .............................. OK


SERIAL INFO
VERSION: 05 00 VENDOR: 01 47

ZME_CAPABILITIES
UID: BE 8E 39 F0 1B 6F 92 84 F3 CC FC A1 CA EC 99 E5
VENDOR: 00 00 NODES: FF
FLAGS: 01 00 00 00 00 00 00 00 00 00 00 00 00

FIRMWARE CRC
BOOT: FF FF FW: FF FF
MISC
FREQ: N/A

NVR Content
--------------------------------------------------------------------------------------------
Prog/erase lock : FF FF FF FF FF FF FF FF, Read back lock: FF
Rev FF, Cal FF, TXCal FF FF, SAW FF FF FF FF, Pin FF, CRC FF FF
NMV: CS FF, TYPE FF, SIZE FF FF, PSIZE FF FF (EEPROM Unknown)
USB: VID FF FF, PID FF FF, UUID FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
--------------------------------------------------------------------------------------------
FACTORY ID: WEEK 255, YEAR 255, CHIP FF FF, SER FF FF, WS 255, HWREV: FF FF, CRC8 FF

elapsed 65.4407582283 seconds

The third one:
./ZMESerialUpdater serialapi_freq -d /dev/ttyAMA0 ANZ

Z-WAVE Serial API Tool
Version:LWE0.9
by Z-WAVE>ME


Openning port .............................. OK

After executing the first command again
-->
Device ready in:1.04658293724 seconds
BOOTLODER
Openning port .............................. OK
Writing NVM data .............................. OK
Waiting for Boot reflashing .............................. OK
-->
Device ready in:1.03767991066 seconds
FIRMWARE
Openning port .............................. OK
Writing NVM data .............................. OK
Setting update flag .............................. OK
Reseting chip .............................. OK
Waiting for FW reflashing .............................. OK
-->
Device ready in:1.05330109596 seconds
FULL INFO
Openning port .............................. OK

Checking the version, resulted in this[/]
VERSION: 05 00 VENDOR: 01 47
FREQ: N/A



I thought it would no mention that I`m on a higher version, 05.07 or something

Post Reply