Aeonlabs Miniremote configuration

Discussions about existing Z-Wave device and their usage with Z-Way/Z-Cloud/Z-Box
User avatar
PoltoS
Posts: 3787
Joined: 26 Jan 2011 19:36

Aeonlabs Miniremote configuration

Post by PoltoS » 02 Jun 2011 17:25

Aeonlabs Miniremote is a very enhanced device with lots of available functions, but unfortunately it is quite hard to configure. Here we preset a config file for Z-Way/Z-Cloud/Z-Box that configures it automatically to send SceneActivation commands to the controller. Using this config one can configure Z-Way to distinguish different buttons and short/long press on this remote. Download the configuration file (use Save link as in your browser), go to Device Configuration tab in Z-Way, choose Miniremote on the left, press on the Action with configurations link, press Import configuration from file button and select the downloaded file. Press Apply configuration for this device. You shall see that the Number of packaet to be sent will become non-zero. Wake up the device holding Learn button for three seconds. Once the config was uploaded to the remote, each button press will result in event comming to the Z-Way. To use it for scene switching in Z-Way go to Rules tab and make a rule that checks for event type Scene comming from the remote. The following IDs for scenes are used: ButtonsActions Short press Long press Left top 11 12 Right top 21 22 Left bottom 31 32 Right bottom 41 42 Note that using this config you are supposed to have Z-Way having nodeId = 1 (your original primary is Z-Way). This configuration switches the remote into so called "Scene" mode (according to Aeonlabs names of modes), which uses AssociationCommandConfiguration. You can configure the remote to do other things using this Command Class using configuration parameters 1-19, 21-39, ..., 121-139, 141-149. Parameters 0, 20, 40, 60, 80, 100, 120 and 140 are used by this configuration.UPDAnother usefull application of this device is the control of Fibaro FGS-221 double switch second channel. Use the following configuration file to make right top button send MultiChannel commands on channel two of node 1 (1:2). As described above, change nodeId, channelId and value of Basic Set to be sent on tap (and hold events as follows: [ 60 (40 for tab, 60 for hold), 1 (node Id), [0x60, 0x0d, 0x01, 0x02 (destination channel Id), 0x20, 0x01, 0x00 (value)]Have fun!

navid
Posts: 1
Joined: 16 Jul 2011 23:09

Triggering Rules

Post by navid » 02 Jun 2011 17:25

Thanks for the writeup, I followed these instructions, but I am still not able to trigger Scenes from my minimote. Here are some screenshots of my configuration:

http://dl.dropbox.com/u/3538640/Screen1.JPG
http://dl.dropbox.com/u/3538640/Screen2.JPG

Am I doing something wrong? The minimote was configured with the xml file (the light was blinking rapidly during the process) But I have still not gotten it to "interview" or trigger any scenes. Any suggestions?
Thanks.


User avatar
PoltoS
Posts: 3787
Joined: 26 Jan 2011 19:36

The device does not pass the interview correctly

Post by PoltoS » 02 Jun 2011 17:25

It has a very strange firmware. Try the following:
0. Check the log file (in expert mode press View Log on Network management tab). If you see events on each button press, the problem is not in device, but in Rules. If you don't see any event pressing buttons, continue this instruction.
1. In expert mode press Force Interview on the bottom of Device Config tab for your miniremote device
2. Try to wake up the device several times (pressing Learn button 3 seconds). Wait about 5-10 seconds between each wake up.
3. After it passes as much as possible import the config again
4. Press Apply button
5. Wake up the device again
6. Everything should work now - you will see events in logging

Hope this will help

nsaq70
Posts: 4
Joined: 24 Sep 2011 13:09

Interview failed after several attempts

Post by nsaq70 » 02 Jun 2011 17:25

I have been struggling to include my Minimote in Z-Way without any success. I can't get the interview phase to complete. I have followed the above instructions without any luck.

My Minimote had firmware version 1.11. I performed a reset of my Minimote before inclusion.

I would like to use the Minimote as a scene controller, but can't even get it interviewed correctly.

Anny suggestions?

User avatar
PoltoS
Posts: 3787
Joined: 26 Jan 2011 19:36

Unfortunately we do not have Minimote v1.11

Post by PoltoS » 02 Jun 2011 17:25

We can probably try to find one and test, but AFAIK, all Minimote we have tested previously, none of them finished the interview due some bugs in device firmware.

But even without interview finished the device can work and be associated with PC controller (Z-Way/Z-Cloud) or any other device.

Try anyway to use the proposed configuration and upload it to the Minimote after the interview would fail completely.

nsaq70
Posts: 4
Joined: 24 Sep 2011 13:09

Error applying configuration

Post by nsaq70 » 02 Jun 2011 17:25

The steps I took
- I included my MiniMote and waited until the interview finished (failed)
- I imported the configuration file
- I pressed the "Apply configuration for this device"
- Error: Command execution failed due to some error on the server

The logfile contains the following errors

2011-09-25 16:58:50,569 Z-Wave.INFO Send to device 11, instance 0, configuration set 245 = 0: Not delivered to recipient
2011-09-25 16:58:50,300 WebSrv.ERROR Bad request /ZWaveAPI/Run/devices[11].instances[0].commandClasses[155].Set(140,1,[0x2B,0x01,42]): Command not found: /ZWaveAPI/Run/devices[11].instances[0].commandClasses[155].Set(140,1,[0x2B,0x01,42])
2011-09-25 16:58:50,300 Except.CRITICAL Error handling web request: /ZWaveAPI/Run/devices[11].instances[0].commandClasses[155].Set(140,1,[0x2B,0x01,42])
2011-09-25 16:58:50,300 Except.CRITICAL KeyError: 155
2011-09-25 16:58:50,299 Except.CRITICAL File "", line 1, in
2011-09-25 16:58:50,299 Except.CRITICAL File "/var/pyzw/pyzw/WebServer.py", line 174, in do_POST
2011-09-25 16:58:50,298 Except.CRITICAL Traceback (most recent call last):

It looks like the "command class" 155 (9B) is invalid.

What am I missing?

User avatar
PoltoS
Posts: 3787
Joined: 26 Jan 2011 19:36

Your Aeonlabs Minimote v1.11 seems to be very different from v1

Post by PoltoS » 02 Jun 2011 17:25

Your Minimote v1.11 seems to not support AssociationCommandConfiguration Command Class. Our description refers to previous version of Minimote supporting it.

We have not tested yet new Minimote. It probably have no AssociationCommandConfiguration and have SceneActivation CommandClass.

Could you please send us the list of supported Command Classes. To do it, switch to Expert mode, then on Device Config tab press Show interview results (under last cut-link at the bottom of the page). If it has SceneActivation, you can use it for configuration

nsaq70
Posts: 4
Joined: 24 Sep 2011 13:09

The response of the device is completly off

Post by nsaq70 » 02 Jun 2011 17:25

 I think the problem is more complex. It looks like the communication between Z-Way and the minimote is not in sync. I have 2 devices and both show the same behavior.The log entries of an include session 2011-09-29 21:05:41,454 Z-Wave.INFO     Send to device 5, instance 0, command class 0x86 version get: Delivered2011-09-29 21:05:41,067 Z-Wave.ERROR    CAN found while no job awaiting ACK...2011-09-29 21:05:41,057 Z-Wave.INFO     Send to device 5, instance 0, command class 0x85 version get: Delivered2011-09-29 21:05:40,924 Z-Wave.ERROR    SendData callback Id is invalid: 0x65! Probably too late2011-09-29 21:05:40,923 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:40,900 Z-Wave.INFO     Send to device 5, instance 0, command class 0x72 version get: Delivered2011-09-29 21:05:40,883 Z-Wave.ERROR    A response received with no request!2011-09-29 21:05:40,761 Z-Wave.ERROR    CAN found while no job awaiting ACK...2011-09-29 21:05:40,608 Z-Wave.INFO     Send to device 5, instance 0, command class 0x70 version get: Delivered2011-09-29 21:05:40,502 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:40,456 Z-Wave.ERROR    SendData callback Id is invalid: 0x63! Probably too late2011-09-29 21:05:40,444 Z-Wave.INFO     Send to device 5, instance 0, version get: Delivered2011-09-29 21:05:39,985 Z-Wave.INFO     Running wakeup handler for node 52011-09-29 21:05:39,984 CmdCls.INFO     Node 5:0, CC Version Interview started2011-09-29 21:05:39,984 CmdCls.INFO     Interview step 12011-09-29 21:05:39,983 CmdCls.INFO     Node 5:0, CC Wakeup: Wakeup notification2011-09-29 21:05:39,743 Z-Wave.ERROR    SendData callback Id is invalid: 0x62! Probably too late2011-09-29 21:05:39,700 Z-Wave.INFO     Send to device 5, instance 0, command class 0x86 version get: Delivered2011-09-29 21:05:39,635 Z-Wave.ERROR    A response received with no request!2011-09-29 21:05:39,624 Z-Wave.ERROR    ACK received, but no job waiting for ACK2011-09-29 21:05:39,322 Z-Wave.ERROR    SendData callback Id is invalid: 0x61! Probably too late2011-09-29 21:05:39,320 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:39,280 Z-Wave.INFO     Send to device 5, instance 0, command class 0x85 version get: Delivered2011-09-29 21:05:38,824 Z-Wave.INFO     Send to device 5, instance 0, command class 0x72 version get: Delivered2011-09-29 21:05:38,783 Z-Wave.ERROR    A response received with no request!2011-09-29 21:05:38,740 Z-Wave.ERROR    CAN found while no job awaiting ACK...2011-09-29 21:05:38,595 Z-Wave.INFO     Send to device 5, instance 0, command class 0x70 version get: Delivered2011-09-29 21:05:38,482 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:38,451 Z-Wave.ERROR    SendData callback Id is invalid: 0x5e! Probably too late2011-09-29 21:05:38,439 Z-Wave.INFO     Send to device 5, instance 0, version get: Delivered2011-09-29 21:05:37,985 Z-Wave.INFO     Running wakeup handler for node 52011-09-29 21:05:37,982 CmdCls.INFO     Node 5:0, CC Version Interview started2011-09-29 21:05:37,982 CmdCls.INFO     Interview step 12011-09-29 21:05:37,980 CmdCls.INFO     Node 5:0, CC Wakeup: Wakeup notification2011-09-29 21:05:37,752 Z-Wave.ERROR    SendData callback Id is invalid: 0x5d! Probably too late2011-09-29 21:05:37,708 Z-Wave.INFO     Send to device 5, instance 0, command class 0x86 version get: Delivered2011-09-29 21:05:37,653 Z-Wave.ERROR    A response received with no request!2011-09-29 21:05:37,642 Z-Wave.ERROR    ACK received, but no job waiting for ACK2011-09-29 21:05:37,341 Z-Wave.ERROR    SendData callback Id is invalid: 0x5c! Probably too late2011-09-29 21:05:37,340 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:37,308 Z-Wave.INFO     Send to device 5, instance 0, command class 0x85 version get: Delivered2011-09-29 21:05:36,869 Z-Wave.INFO     Send to device 5, instance 0, command class 0x72 version get: Delivered2011-09-29 21:05:36,838 Z-Wave.ERROR    A response received with no request!2011-09-29 21:05:36,828 Z-Wave.ERROR    ACK received, but no job waiting for ACK2011-09-29 21:05:36,797 Z-Wave.ERROR    SendData callback Id is invalid: 0x5a! Probably too late2011-09-29 21:05:36,734 Z-Wave.ERROR    CAN found while no job awaiting ACK...2011-09-29 21:05:36,722 Z-Wave.INFO     Send to device 5, instance 0, command class 0x70 version get: Delivered2011-09-29 21:05:36,660 Z-Wave.ERROR    CAN found while no job awaiting ACK...2011-09-29 21:05:36,649 Z-Wave.ERROR    SendData callback Id is invalid: 0x5a! Probably too late2011-09-29 21:05:36,649 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:36,628 Z-Wave.ERROR    A response received with no request!2011-09-29 21:05:36,618 Z-Wave.ERROR    ACK received, but no job waiting for ACK2011-09-29 21:05:36,576 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:36,541 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:36,460 Z-Wave.ERROR    SendData callback Id is invalid: 0x59! Probably too late2011-09-29 21:05:36,459 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:36,416 Z-Wave.INFO     Send to device 5, instance 0, version get: Delivered2011-09-29 21:05:35,986 Z-Wave.INFO     Running wakeup handler for node 52011-09-29 21:05:35,984 CmdCls.INFO     Node 5:0, CC Version Interview started2011-09-29 21:05:35,984 CmdCls.INFO     Interview step 12011-09-29 21:05:35,983 CmdCls.INFO     Node 5:0, CC Wakeup: Wakeup notification2011-09-29 21:05:35,979 Z-Wave.INFO     Got frame from device 5 to controller, but command class 84 for device is not registered - instanciating it as not supported2011-09-29 21:05:31,687 Z-Wave.ERROR    CAN found while no job awaiting ACK...2011-09-29 21:05:31,676 Z-Wave.INFO     Send to device 5, instance 0, command class 0x86 version get: Delivered2011-09-29 21:05:31,553 Z-Wave.ERROR    SendData callback Id is invalid: 0x57! Probably too late2011-09-29 21:05:31,552 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:31,509 Z-Wave.INFO     Send to device 5, instance 0, command class 0x85 version get: Delivered2011-09-29 21:05:31,453 Z-Wave.ERROR    A response received with no request!2011-09-29 21:05:31,442 Z-Wave.ERROR    ACK received, but no job waiting for ACK2011-09-29 21:05:31,135 Z-Wave.ERROR    SendData callback Id is invalid: 0x56! Probably too late2011-09-29 21:05:31,134 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:31,113 Z-Wave.INFO     Send to device 5, instance 0, command class 0x72 version get: Delivered2011-09-29 21:05:31,100 Z-Wave.ERROR    A response received with no request!2011-09-29 21:05:30,958 Z-Wave.ERROR    CAN found while no job awaiting ACK...2011-09-29 21:05:30,815 Z-Wave.INFO     Send to device 5, instance 0, command class 0x70 version get: Delivered2011-09-29 21:05:30,751 Z-Wave.ERROR    CAN found while no job awaiting ACK...2011-09-29 21:05:30,699 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:30,667 Z-Wave.ERROR    SendData callback Id is invalid: 0x54! Probably too late2011-09-29 21:05:30,667 Z-Wave.ERROR    SOF found while awaiting ack...2011-09-29 21:05:30,622 Z-Wave.INFO     Send to device 5, instance 0, version get: Delivered2011-09-29 21:05:30,193 Z-Wave.INFO     Get routing table line: List of neighbours for node 5: []2011-09-29 21:05:29,897 Z-Wave.INFO     Get routing table line: List of neighbours for node 1: []2011-09-29 21:05:29,590 Z-Wave.INFO     Check if node is failed: Node 5 is operating2011-09-29 21:05:28,972 Z-Wave.INFO     Add/re-include node to network: Start: Done2011-09-29 21:05:28,625 Z-Wave.INFO     Running wakeup handler for node 52011-09-29 21:05:28,619 CmdCls.INFO     Node 5:0, CC Version Interview started2011-09-29 21:05:28,617 CmdCls.INFO     Interview step 12011-09-29 21:05:28,614 CmdCls.INFO     Device 5, instance 0 supports Command Class Version2011-09-29 21:05:28,612 CmdCls.INFO     Device 5, instance 0 supports Command Class Association2011-09-29 21:05:28,610 CmdCls.INFO     Device 5, instance 0 supports Command Class ManufacturerSpecific2011-09-29 21:05:28,605 CmdCls.INFO     Device 5, instance 0 supports Command Class Configuration2011-09-29 21:05:28,602 CmdCls.INFO     Loading Command Classes for device 52011-09-29 21:05:28,600 Z-Wave.INFO     Add/re-include node to network: Start: Protocol done2011-09-29 21:05:28,548 Z-Wave.INFO     Function id 0xa6 IsVirtualNode is not supported - job not queued2011-09-29 21:05:28,534 Z-Wave.INFO     Add/re-include node to network: Start: Adding controller: node 52011-09-29 21:05:28,212 Z-Wave.INFO     Add/re-include node to network: Start: Node found: node 02011-09-29 21:05:25,574 Z-Wave.INFO     Add/re-include node to network: Start: Ready to add - push button on the device to be added2011-09-29 21:05:25,541 Z-Wave.INFO     Add/re-include node to network: Start: Ready to add - push button on the device to be added Does this maken any sence to you? Ik woul love to downgrade my Minimote, but EAON-Labs only has het 1.1 formware available on their website.

User avatar
PoltoS
Posts: 3787
Joined: 26 Jan 2011 19:36

It seems your internet connection has big delays toward Z-Cloud

Post by PoltoS » 02 Jun 2011 17:25

Aeonlabs Minimote is very critical to timing and delays in communications would certainly affect interview results. Your internet connection seems to have big delays toward Z-Cloud service.

Can you do ping?
Do other devices work with Z-Cloud? Do they pass interview after inclusion?

If you are in Danmark, this might be also caused by Z-Wave enabled power meters installed by your utility company. We have seen such problems earlier.

nsaq70
Posts: 4
Joined: 24 Sep 2011 13:09

High ping times

Post by nsaq70 » 02 Jun 2011 17:25

I have a fast internet connection (Speedtest.net: 30Mbps down/ 6Mbps up) so that shouldn't be the problem, but ping times are relative high to z-cloud.z-wave.me: between 35 en 40 ms.
I did some tests on my brothers internet connection (different provider) and they were even higher (45-50 ms).

Other devices work fine. I have tested a Duwi Schuko Plug Switch and a zwave.me insert dimmer(which is still identified as a Duwi?).

I live in The Netherlands and don't have a Z-Wave enabled power meter. I do own a couple of other Duwi devices that are connected to each other without a central unit. Could this cause problems?

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests