Issues with HRT4-ZW thermostat

Discussions about existing Z-Wave device and their usage with Z-Way/Z-Cloud/Z-Box
Post Reply
babelmonk
Posts: 3
Joined: 17 Dec 2016 14:40

Issues with HRT4-ZW thermostat

Post by babelmonk » 14 Feb 2017 14:33

I've had no end of problems getting the UI to play nicely with this 'stat.

Using the API / an App to change the set temperature works OK - the device updates after the wakeup interval as I'd expect.

However, in the UI, the value goes back and forth endlessly if I try to set it - and it's nearly impossible to get the right number. In addition, there is a set of exceptions in the log for every change.

I've uploaded a GIF animation of what happens, logged errors in the UI and the z-way-server.log file excerpt (below). Any hints would be appreciated.

Code: Select all

92340 [2017-02-14 09:43:33.647] [D] [zway] RECEIVED: ( 01 0B 00 04 00 13 05 31 05 05 01 27 F1 )
92341 [2017-02-14 09:43:33.647] [D] [zway] SENT ACK
92342 [2017-02-14 09:43:33.647] [D] [zway] SETDATA devices.19.data.lastReceived = 0 (0x00000000)
92343 [2017-02-14 09:43:33.647] [D] [zway] SETDATA devices.19.instances.0.commandClasses.49.data.5.deviceScale = 0 (0x00000000)
92344 [2017-02-14 09:43:33.647] [D] [zway] SETDATA devices.19.instances.0.commandClasses.49.data.5.scale = 0 (0x00000000)
92345 [2017-02-14 09:43:33.648] [D] [zway] SETDATA devices.19.instances.0.commandClasses.49.data.5.scaleString = "%"
92346 [2017-02-14 09:43:33.648] [D] [zway] SETDATA devices.19.instances.0.commandClasses.49.data.5.val = 39.000000
92347 [2017-02-14 09:43:33.648] [D] [zway] SETDATA devices.19.instances.0.commandClasses.49.data.5 = Empty
92348 [2017-02-14 09:43:35.354] [I] [core] ---  ZWayVDev_zway_44-0-67-1 performCommand processing: {"0":"exact","1":{"level":"2"}}
92349 [2017-02-14 09:43:35.355] [D] [zway] SETDATA devices.44.instances.0.commandClasses.67.data.1.setVal = 2.000000
92350 [2017-02-14 09:43:35.355] [I] [zway] Adding job: ThermostatSetPoint Set
92351 [2017-02-14 09:43:35.356] [I] [zway] Adding job: ThermostatSetPoint Get
92352 [2017-02-14 09:43:35.356] [I] [zway] Node 44:0 CC ThermostatMode: Thermostat Mode 1 is not supported by device (modemask 0x0)
92353 [2017-02-14 09:43:35.361] [I] [core] Notification: error (module): Error during perform command execution: Error: Invalid argument
92354 [2017-02-14 09:43:35.369] [I] [core] Error: Invalid argument
92355     at Error (native)
92356     at t_vDev.(anonymous function).self.controller.devices.create.handler (automation/modules/ZWave/index.js:3356:61)
92357     at _.extend.performCommand (automation/classes/VirtualDevice.js:295:37)
92358     at ZAutomationAPIWebRequest._.extend.performVDevCommandFunc (automation/ZAutomationAPIProvider.js:377:60)
92359     at ZAutomationAPIWebRequest.handlerFunc (automation/ZAutomationAPIProvider.js:3032:52)
92360     at ZAutomationAPIWebRequest.ZAutomationWebRequest.handleRequest (automation/WebserverRequestRouter.js:259:41)
92361     at automation/WebserverRequestRouter.js:32:35
92362     at WebServer.document_root (automation/Webserver.js:35:11)
92363 [2017-02-14 09:43:35.376] [I] [core] Notification: device-info (device-status): {"dev":"Hallway Thermostat SetPoint","l":"2 °C"}
92364 [2017-02-14 09:43:35.420] [I] [core] [BaseModule-26] Set lastLevel to 2 for ZWayVDev_zway_44-0-67-1 (was 15)
92365 [2017-02-14 09:43:35.620] [I] [core] ---  ZWayVDev_zway_44-0-67-1 performCommand processing: {"0":"exact","1":{"level":"21.5"}}
92366 [2017-02-14 09:43:35.620] [D] [zway] SETDATA devices.44.instances.0.commandClasses.67.data.1.setVal = 21.500000
92367 [2017-02-14 09:43:35.621] [I] [zway] Adding job: ThermostatSetPoint Set
92368 [2017-02-14 09:43:35.621] [D] [zway] Job 0x13 (ThermostatSetPoint Get): removing duplicate
92369 [2017-02-14 09:43:35.621] [I] [zway] Node 44:0 CC ThermostatMode: Thermostat Mode 1 is not supported by device (modemask 0x0)
92370 [2017-02-14 09:43:35.622] [I] [core] Notification: error (module): Error during perform command execution: Error: Invalid argument
92371 [2017-02-14 09:43:35.626] [I] [core] Error: Invalid argument
92372     at Error (native)
92373     at t_vDev.(anonymous function).self.controller.devices.create.handler (automation/modules/ZWave/index.js:3356:61)
92374     at _.extend.performCommand (automation/classes/VirtualDevice.js:295:37)
92375     at ZAutomationAPIWebRequest._.extend.performVDevCommandFunc (automation/ZAutomationAPIProvider.js:377:60)
92376     at ZAutomationAPIWebRequest.handlerFunc (automation/ZAutomationAPIProvider.js:3032:52)
92377     at ZAutomationAPIWebRequest.ZAutomationWebRequest.handleRequest (automation/WebserverRequestRouter.js:259:41)
92378     at automation/WebserverRequestRouter.js:32:35
92379     at WebServer.document_root (automation/Webserver.js:35:11)
92380 [2017-02-14 09:43:35.629] [I] [core] Notification: device-info (device-status): {"dev":"Hallway Thermostat SetPoint","l":"21.5 °C"}
92381 [2017-02-14 09:43:35.662] [I] [core] [BaseModule-26] Set lastLevel to 21.5 for ZWayVDev_zway_44-0-67-1 (was 2)
92382 [2017-02-14 09:44:02.637] [D] [zway] RECEIVED: ( 01 08 00 04 00 30 02 98 40 19 )
92383 [2017-02-14 09:44:02.637] [D] [zway] SENT ACK
92384 [2017-02-14 09:44:02.637] [D] [zway] SETDATA devices.48.data.lastReceived = 0 (0x00000000)
92385 [2017-02-14 09:44:02.639] [I] [zway] Node 48:0 CC Security: sending Nonce Report
92386 [2017-02-14 09:44:02.639] [I] [zway] Adding job: Nonce Report
92387 [2017-02-14 09:44:02.640] [D] [zway] SENDING (cb 0xcb): ( 01 11 00 13 30 0A 98 80 52 20 EE 3B 9E 9F 69 B7 25 CB 49 )
92388 [2017-02-14 09:44:02.643] [D] [zway] RECEIVED ACK
92389 [2017-02-14 09:44:02.649] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
92390 [2017-02-14 09:44:02.649] [D] [zway] SENT ACK
92391 [2017-02-14 09:44:02.649] [D] [zway] Delivered to Z-Wave stack
Attachments
zwave thermostat issue.gif
Animated issue with UI
zwave thermostat issue.gif (412 KiB) Viewed 301 times
ThermostatIssueErrors.PNG
Errors in UI
ThermostatIssueErrors.PNG (158.31 KiB) Viewed 301 times


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest