Zipato Multisensor 4 in 1

Discussions about existing Z-Wave device and their usage with Z-Way/Z-Cloud/Z-Box
Post Reply
tommy2d
Posts: 3
Joined: 02 Oct 2017 23:42

Zipato Multisensor 4 in 1

Post by tommy2d » 02 Oct 2017 23:51

Hi,

I just bought a Zipato Multisensor 4 in 1 device, and I have problems getting it to finish the interview. Please refer to my log file. It fails when trying to determine the version, returning 10 bytes instead of 11.

What to do?

Code: Select all

[2017-10-02 22:47:03.673] [D] [zway] Received reply on job (Version Get)
[2017-10-02 22:47:03.673] [D] [zway] SETDATA devices.18.instances.0.commandClasses.134.data = Empty
[2017-10-02 22:47:03.674] [D] [zway] SETDATA devices.18.instances.0.commandClasses.134.data.ZWLib = 3 (0x00000003)
[2017-10-02 22:47:03.674] [D] [zway] SETDATA devices.18.instances.0.commandClasses.134.data.ZWProtocolMajor = 4 (0x00000004)
[2017-10-02 22:47:03.674] [D] [zway] SETDATA devices.18.instances.0.commandClasses.134.data.ZWProtocolMinor = 5 (0x00000005)
[2017-10-02 22:47:03.675] [D] [zway] SETDATA devices.18.instances.0.commandClasses.134.data.SDK = "6.51.06"
[2017-10-02 22:47:03.676] [D] [zway] SETDATA devices.18.instances.0.commandClasses.134.data.applicationMajor = 6 (0x00000006)
[2017-10-02 22:47:03.676] [D] [zway] SETDATA devices.18.instances.0.commandClasses.134.data.applicationMinor = 1 (0x00000001)
[2017-10-02 22:47:03.676] [D] [zway] SETDATA devices.18.data.ZWLib = 3 (0x00000003)
[2017-10-02 22:47:03.676] [D] [zway] SETDATA devices.18.data.ZWProtocolMajor = 4 (0x00000004)
[2017-10-02 22:47:03.676] [D] [zway] SETDATA devices.18.data.ZWProtocolMinor = 5 (0x00000005)
[2017-10-02 22:47:03.678] [D] [zway] SETDATA devices.18.data.SDK = "6.51.06"
[2017-10-02 22:47:03.678] [D] [zway] SETDATA devices.18.data.applicationMajor = 6 (0x00000006)
[2017-10-02 22:47:03.678] [D] [zway] SETDATA devices.18.data.applicationMinor = 1 (0x00000001)
[2017-10-02 22:47:03.678] [E] [zway] Packet CC::VERSION_REPORT (v2) is too short: required at least 11 bytes, got 10
[2017-10-02 22:47:03.678] [E] [zway] Error returned from _zway_cc_call_handler(zway, command, controller->id, 0, data[4], &data[5]): Wrong packet from Z-Wave network or Discovery got bad data (stick communication failed) (-9)

tommy2d
Posts: 3
Joined: 02 Oct 2017 23:42

Re: Zipato Multisensor 4 in 1

Post by tommy2d » 10 Oct 2017 16:21

Anyone?

If there isn's a solution to this problem, maybe we should at least blacklist the device?

For reference, this is the manual:

https://www.zipato.com/wp-content/uploa ... l-v1.0.pdf

tommy2d
Posts: 3
Joined: 02 Oct 2017 23:42

Re: Zipato Multisensor 4 in 1

Post by tommy2d » 25 Oct 2017 22:10

I also contacted the vendor, but they state they need a zniffer report in order to be able to help me. Since I cannot legally acquire this tool, I'm not able to deliver anything but the log file that I attached in the thread. Is there any way I can just dump the raw communication using z-way?

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests