EUROtronics Spirit Z direct valve control

Discussions about existing Z-Wave device and their usage with Z-Way/Z-Cloud/Z-Box
Post Reply
John Smith
Posts: 13
Joined: 23 Sep 2018 17:52

EUROtronics Spirit Z direct valve control

Post by John Smith » 09 Oct 2018 17:24

Can't manage to turn this on in z-way.

Docs state that there should be another thermostat mode: 0x1F (31), that should enable multilevel switch and control valve directly.

Image

The switch is reported during the interview

Image

The problem is that there are no such mode in expert config parameters

Image

and multilevel switch is not visible in the home automation interface, but visible in expert one with 0 to 0 range:

Image

In Spirit's docs there is a reference that we need to also send some basic command class command to enable it

Image

I've seen a lot of docs how to do it on an another controller, but can't achieve it in zway

1. How to send a custom basic class command?
2. How to add another thermostat mode?

Please, give me any clues where to look.

Thank you!

John Smith
Posts: 13
Joined: 23 Sep 2018 17:52

Re: EUROtronics Spirit Z direct valve control

Post by John Smith » 09 Oct 2018 17:40

Interview didn't complete due to security modes

Image

steverock
Posts: 8
Joined: 14 Nov 2018 09:12

Re: EUROtronics Spirit Z direct valve control

Post by steverock » 14 Nov 2018 12:04

Hi, I've done this way:
in the expert UI: configuration tab, select Spirit device and go to expert commands.
You will find, at first row, "Basic CommandClass". Set value 254 (0xFE - Manufacturer Specific).

Then scroll down to second row "SwitchMultiLevel" and set parameter as you want.
In this way I can manually control the valve aperture. (I tried with some values and the valve respondy correctly).

Probably after putting valve in "manufacturer mode" you will able to set aperture also with slider (I have not tried this yet)

mikelspikel
Posts: 2
Joined: 23 Mar 2018 16:50

Re: EUROtronics Spirit Z direct valve control

Post by mikelspikel » 12 Feb 2019 19:27

I have the same device and had the same difficuities while trying to use direct valve control mode.
Once you follow steverock's steps to set manufacturer specific mode you can already control the valve aperture using the expert interface but, as you say, there is no multilevel switch device in home automation interface. The reason seems to be that the multilevel switch device is disabled in postfix.json.
Open /opt/z-way-server/automation/modules/ZWave/postfix.json and look for Eurotronic Spirit. The postInterview postfix disables the multilevel switch vDev (0-38). I enabled it by changing:

Code: Select all

"postInterview": ["renameNode,Eurotronic Spirit", "rename,0-64,Eurotronic Thermostat operation", "rename,0-67-1,Eurotronic Thermostat Heat", "rename,0-49-1,Eurotronic Thermostat Temperature", "noVDev,0-113-9-4", "noVDev,0-38", "hide,0-38", "hide,0-113-8-10", "hide,0-113-8-11", "hide,0-113-9-3"]
to

Code: Select all

"postInterview": ["renameNode,Eurotronic Spirit", "rename,0-64,Eurotronic Thermostat operation", "rename,0-67-1,Eurotronic Thermostat Heat", "rename,0-49-1,Eurotronic Thermostat Temperature", "rename,0-38,Eurotronic Direct Valve Control", "noVDev,0-113-9-4", "hide,0-113-8-10", "hide,0-113-8-11", "hide,0-113-9-3"]

Post Reply