[userModule] Virtual Rain Sensor (Updated 2016/07/31)

Tips, Tricks and Scripts to enhance your home automation and workaround known device bugs, limitations and incompatibilities
Mike Yeager
Posts: 160
Joined: 03 May 2014 07:02

Re: [userModule] Virtual Rain Sensor (Updated 2016/01/08)

Post by Mike Yeager » 10 Jun 2016 21:20

I've been looking at the way the module works and it appears to check it's status every 15 minutes. That being the case, I'm considering piggybacking the timer that's already in the module with a boot persistent entry in the metrics that adds the delay time to the current time and then compares it each pass through to determine if it's timed out of the delay cycle. If the program has been restarted and the delay timer has been lost, the most the delay time would be off by is 15 minutes. Needless to say, for a rain delay on an irrigation system, this isn't a big deal. If the system hasn't been restarted, then the original timer would clear the delay and all would be good. Does this sound reasonable? I thought about a way to reset the timer on restart but I'm just not sure it's that important...

Update - I thought about it a bit more and determined that it would be easy enough to catch this early in the process and actually restore the timer, thereby not altering the function of the original module much at all. I'm testing the modifications now...

After a little scratching of my head over something I should have caught early, I have it working the way I expected. I justhink need a rain event now to finish the testing phase. I'd like to offer the changes to you to include in the official module as I'd really rather not have to update this version as you update yours.

joerod
Posts: 11
Joined: 26 Nov 2015 17:49

Re: [userModule] Virtual Rain Sensor (Updated 2016/01/08)

Post by joerod » 18 Jun 2016 04:18

I've love to start using this sensor but I'm having a hard time getting it to work. The app installs correctly and I have WeatherUndergound module installed and working properly, however when I try and add a rain sensor I do not see any options for my weather app. Anyone have any ideas?

maros
Posts: 103
Joined: 05 Apr 2014 11:21

Re: [userModule] Virtual Rain Sensor (Updated 2016/01/08)

Post by maros » 18 Jun 2016 09:58

That's because there in no option to select the weather app. The weather module will be detected automatically. Make sure you have my WeatherUndergound module installed, and not Wunderground for the rain sensor to work properly
Z-Way 2.2.4 on Raspi B | My Zway GitHub repos | Amazon Wishlist to support module development

Mike Yeager
Posts: 160
Joined: 03 May 2014 07:02

Re: [userModule] Virtual Rain Sensor (Updated 2016/06/01)

Post by Mike Yeager » 22 Jun 2016 02:56

maros,

I am pretty sure I have the code worked out to make the delay time not reboot safe. I realize that the reason I set out to do this was outside of the original scope of your excellent module, but if you'd like the code to look over, it's at your disposal...

maros
Posts: 103
Joined: 05 Apr 2014 11:21

Re: [userModule] Virtual Rain Sensor (Updated 2016/06/01)

Post by maros » 24 Jun 2016 11:39

Mike Yeager wrote:I am pretty sure I have the code worked out to make the delay time not reboot safe. I realize that the reason I set out to do this was outside of the original scope of your excellent module, but if you'd like the code to look over, it's at your disposal...
sure, just create a github pullrequest and I'll be happy to review it.
Z-Way 2.2.4 on Raspi B | My Zway GitHub repos | Amazon Wishlist to support module development

Mike Yeager
Posts: 160
Joined: 03 May 2014 07:02

Re: [userModule] Virtual Rain Sensor (Updated 2016/06/01)

Post by Mike Yeager » 25 Jun 2016 03:55

I'll see if I can't get that figured out over the weekend. I'm not much of a Github person. I use it to store my own stuff but...

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest