Ping Presence State doesn't work with v2.3.0

Tips, Tricks and Scripts to enhance your home automation and workaround known device bugs, limitations and incompatibilities
Post Reply
Benny
Posts: 47
Joined: 25 Jan 2017 15:50

Ping Presence State doesn't work with v2.3.0

Post by Benny » 05 Feb 2017 22:21

Hello,

have the problem, after upgrade to 2.3.0 the app ping presence state stoppped working.
Tried some thigs, so I deleted this app an installed new. Didn't work, same after reinstalling this and all dependent apps.

Code: Select all

[2017-02-05 19:38:08.094] [I] [core] --- Starting module Ping Presence state

[2017-02-05 19:39:00.692] [E] [core] Callback execution error: Error: This command is denied by policy
    at Error (native)
    at AutomationController.<anonymous> (automation/userModules/PingPresence/index.js:43:108)
    at AutomationController.EventEmitter.emit (automation/lib/eventemitter2.js:333:30)
    at automation/modules/Cron/index.js:138:42
    at Array.forEach (native)
    at automation/modules/Cron/index.js:126:27
    at Array.forEach (native)
    at Function.<anonymous> (automation/modules/Cron/index.js:123:37)

[2017-02-05 19:39:15.678] [D] [zway] RECEIVED: ( 01 14 00 04 00 02 0E 32 02 21 64 00 00 01 F5 FF FF 00 00 01 F5 96 )

[2017-02-05 19:39:15.678] [D] [zway] SENT ACK
Where is my Mistake? This app worked fine with v2.2.5...

maros
Posts: 103
Joined: 05 Apr 2014 11:21

Re: Ping Presence State doesn't work with v2.3.0

Post by maros » 06 Feb 2017 10:55

You need to whitelist the required scripts/binaries in your .syscommand file. Unfortunately these settings get lost during an upgrade.

@poltos: it would be great if the .syscommand file was migrated during a version upgrade.
Z-Way 2.2.4 on Raspi B | My Zway GitHub repos | Amazon Wishlist to support module development

Benny
Posts: 47
Joined: 25 Jan 2017 15:50

Re: Ping Presence State doesn't work with v2.3.0

Post by Benny » 06 Feb 2017 16:16

you mean

Code: Select all

echo 'ping' >> /opt/z-way-server/automation/.syscommands
echo 'grep' >> /opt/z-way-server/automation/.syscommands
Did it immediately after upgrade.

There is another error:

Code: Select all

[2017-02-05 20:53:00.466] [E] [core] Callback execution error: TypeError: undefined is not a function
    at PingPresence.checkPresence (automation/userModules/PingPresence/index.js:93:8)
    at AutomationController.<anonymous> (automation/userModules/PingPresence/index.js:55:10)
    at AutomationController.EventEmitter.emit (automation/lib/eventemitter2.js:333:30)
    at automation/modules/Cron/index.js:138:42
    at Array.forEach (native)
    at automation/modules/Cron/index.js:126:27
    at Array.forEach (native)
    at Function.<anonymous> (automation/modules/Cron/index.js:123:37)
Comes every minute, until 21:45. At that time Presence switched into night-mode. So I think perhaps something is wrong with Base Module or Presence.

Benny
Posts: 47
Joined: 25 Jan 2017 15:50

Re: Ping Presence State doesn't work with v2.3.0

Post by Benny » 12 Feb 2017 20:50

Did the same again, now it works. Reinstall all apps and reboot the pi, now both are working fine. Don't know why...

Post Reply