Fahrenheit

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
NewfD90
Posts: 12
Joined: 24 Aug 2017 18:40

Fahrenheit

Post by NewfD90 » 25 Aug 2017 23:46

I see SENSOR_MULTILEVEL_SCALE_CELSIUS in the ZUNO_Definitions.h, but not an entry for Fahrenheit.

My controller (Z-Stick/Indigo) will only display in the device's reported units, and I'd like it to be Fahrenheit.

Is that going to be added anytime soon?

User avatar
PoltoS
Posts: 4408
Joined: 26 Jan 2011 19:36

Re: Fahrenheit

Post by PoltoS » 26 Aug 2017 08:58

This value is 0. Replace it with a constant 1 and it should become Fahrenheit. If that does not worth, show me your channel definition

NewfD90
Posts: 12
Joined: 24 Aug 2017 18:40

Re: Fahrenheit

Post by NewfD90 » 26 Aug 2017 19:08

Thanks, I stumbled on to that. And indeed, when included, the controller switches to Fahrenheit.

On another topic, is there a secret to getting Z-Uno to Exclude properly? From day 1, I've never been able to Exclude it.

Inclusions always work.

The only way I've been able to exclude it is with the factory reset (5 sec hold, tap 3x) and deleting the zombie unit out of my controller. Makes development a bit painful.

User avatar
PoltoS
Posts: 4408
Joined: 26 Jan 2011 19:36

Re: Fahrenheit

Post by PoltoS » 26 Aug 2017 19:35

Fast triple click should do the job.

But if your controller supports re-interview, you can enable debug mode in Z-Uno to apply all changes without re-inclusion.

User avatar
PoltoS
Posts: 4408
Joined: 26 Jan 2011 19:36

Re: Fahrenheit

Post by PoltoS » 26 Aug 2017 19:37

Btw, if your new Z-Uno based device works, may be you can share that with the community? We need a description like in the Examples page

NewfD90
Posts: 12
Joined: 24 Aug 2017 18:40

Re: Fahrenheit

Post by NewfD90 » 27 Aug 2017 17:21

PoltoS wrote:
26 Aug 2017 19:35
Fast triple click should do the job.
Right, that's what doesn't work. The Z-Uno's red LED will rapidly flash for a second to two and then go back to running it's program. It doesn't seem to stay in exclusion mode long enough for the controller to recognize it.

I'd be glad to share it once done, but it's nothing complicated: my hot tub has an unused temp sensor (thermistor) and I'm interfacing with that.

Black Cat
Posts: 61
Joined: 02 Mar 2016 00:52

Re: Fahrenheit

Post by Black Cat » 28 Aug 2017 01:30

I've always had problems excluding ZUNO (and other devices) until I moved to HomeSeer.
Now it's a pleasure to exclude/include using the UI.
Not the solution many would want to hear, but it indicates an underlying problem in HA Software. (vera would be the worst in exclude/Include)

buddyedwards1975
Posts: 1
Joined: 13 Jan 2019 02:09

Re: Fahrenheit

Post by buddyedwards1975 » 13 Jan 2019 02:16

Pardon my ignorance, but I haven't been able to figure out where/how to add the constant value to have the Z-UNO push to Smarthings in Fahrenheit. Is this something I do in the device handler or is this something that I can do in the Arduino code? This is really the last thing I need to get done to finish my temp sensor. Everything else is working exactly like I want it to. Any help would be appreciated. Thanks!

User avatar
PoltoS
Posts: 4408
Joined: 26 Jan 2011 19:36

Re: Fahrenheit

Post by PoltoS » 18 Jan 2019 01:18

You can change it in Arduino code (in the channel definition). The default is in C. Check in .h how to expend it and change C to F

Post Reply