Probleme mit RaZberry im Raspberry pi 3

Post Reply
sirsalomon
Posts: 5
Joined: 18 Oct 2017 20:34

Probleme mit RaZberry im Raspberry pi 3

Post by sirsalomon » 18 Oct 2017 22:22

Hallo,

vermutlich gibt es mehr wie ein Beitrag zu diesem Thema, aber ich werde nicht schlau aus den gefundenen, daher mein (erster) Post.

Ich habe ein Raspberry Pi3 mit einem raZberry-Modul. Installiert habe ich das Image von der Seite razberry.z-wave.me, dann noch

apt get update; apt-get upgrade

Und den Raspi neu gestartet. Danach das Firmware-Update durchgeführt und wieder neu gestartet.

Beim Einschalten leuchten jeweils beide LEDs kurz auf, dann startet der Raspi. Nach einer kurzen Zeit blinken beide LEDs wieder auf, das Modul wird vermutlich erkannt. Die IP-Adresse bezieht der Raspberry via DHCP und ist reserviert.

Dennoch erscheinen im z-way-Logfile folgende Einträge:
[2017-10-18 19:13:10.039] [D] [zway] Opened device: /dev/ttyAMA0
[2017-10-18 19:13:10.039] [D] [zway] Worker thread successfully created
[2017-10-18 19:13:10.039] [D] [zway] Worker thread entry point
[2017-10-18 19:13:10.040] [zway] Adding job: Get controller info and supported function classes
[2017-10-18 19:13:10.049] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2017-10-18 19:13:10.251] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2017-10-18 19:13:10.251] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2017-10-18 19:13:10.453] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2017-10-18 19:13:10.453] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2017-10-18 19:13:10.654] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2017-10-18 19:13:10.654] [W] [zway] Job 0x07 (Get controller info and supported function classes) dropped: too many resends
[2017-10-18 19:13:10.654] [D] [zway] Job 0x07 (Get controller info and supported function classes): fail
[2017-10-18 19:13:10.654] [C] [zway] Get Serial API Capabilities returned zero.
[2017-10-18 19:13:10.654] [zway] Removing job: Get controller info and supported function classes
[2017-10-18 19:13:10.664] [D] [zway] Worker thread exit point
[2017-10-18 19:13:10.664] [D] [zway] Worker thread successfully finished
[2017-10-18 19:13:10.675] [E] [zway] SaveData will not save data since it wasn't loaded. This is to prevent data loss.
[2017-10-18 19:13:10.694] [core] Error: Bad data - communication failed
[2017-10-18 19:13:10.695] [core] Tried 5 times without success. Stopping tries.
[2017-10-18 19:13:10.697] [core] Notification: critical (z-wave): Cannot start Z-Wave binding: Error: Bad data - communication failed


Außerdem noch, im Menü "Management":

An unexpected error occurred while initialising the Z-Wave controller data.
Please check
1.) if the controller is plugged in correctly,
2.) that in the app 'Z-Wave Network Access' the right port is entered
(UZB: '/dev/ttyACM0', Box: '/dev/ttyAMA0', UZB-Windows: '\\.\COM3', Z-Stick: '/dev/ttyUSB0', embedded boxes: '/dev/ttyS0' or '/dev/ttyS1')
3.) the app is aktiv. If not you could activate it under Menu > Apps > Activ or add a new one under Menu > Apps > Local.
The Setting 'Expert View' needs to be active under Menu > My Settings.


In der config.txt, im Verzeichnis "/boot" habe ich WLAN und Bluetooth deaktiviert (WLAN ist nicht notwendig bei mir). Die Vorgaben habe ich direkt von dem Image übernommen.

Über ein anderes Image, mit Domoticz als z-Wave-Server, wird das Modul gefunden und mit der Version "1.4-2721-g42ed7e5-dirty" angegeben, aber auch dort kann ich das Modul nicht ansprechen.

Anders gesagt, ich steh völlig auf dem Schlauch und bitte Euch mal freundlichst um Mithilfe, noch besser wäre Lösungen :)

Cmax74
Posts: 46
Joined: 25 Apr 2016 23:00

Re: Probleme mit RaZberry im Raspberry pi 3

Post by Cmax74 » 20 Oct 2017 09:32

Raspi 3, Zwave.me 2.3.6.

sirsalomon
Posts: 5
Joined: 18 Oct 2017 20:34

Re: Probleme mit RaZberry im Raspberry pi 3

Post by sirsalomon » 20 Oct 2017 18:02

Leider nichts, hat keinen Erfolg gebracht. Ich habe sogar das Modul aus der Konfiguration entfernt und neu eingebunden, aber nix geht...

Einzig unter Domoticz bekomme ich immerhin die Firmware angezeigt, wobei ich auch dort kein Setup des Moduls durchführen kann

User avatar
Z-Wave Support
Posts: 263
Joined: 21 Oct 2016 15:49

Re: Probleme mit RaZberry im Raspberry pi 3

Post by Z-Wave Support » 23 Oct 2017 11:47

Hallo,

ich geh davon aus das du den Port einmal neu gesetzt hast. Und das System neugestartet hast.

Wenn du das System neu aufgesetzt hast wie Cmax74 beschrieben hat, sollte es auch funktionieren.

Einzige Möglichkeit wäre vielleicht ein defekt des Moduls.

Du kannst ja mal schauen ob der Port vom Raspberry gefunden wird.

ls -al /dev/tty*


Viele Grüße
Z-Wave Support

sirsalomon
Posts: 5
Joined: 18 Oct 2017 20:34

Re: Probleme mit RaZberry im Raspberry pi 3

Post by sirsalomon » 23 Oct 2017 12:45

Leider keine Besserung, der Port wird aufgelistet.

User avatar
Z-Wave Support
Posts: 263
Joined: 21 Oct 2016 15:49

Re: Probleme mit RaZberry im Raspberry pi 3

Post by Z-Wave Support » 24 Oct 2017 16:47

Hallo,

könnte ein defektes Modul sein, lass es mal am besten austauschen.

Viele Grüße
Z-Wave Support

sirsalomon
Posts: 5
Joined: 18 Oct 2017 20:34

Re: Probleme mit RaZberry im Raspberry pi 3

Post by sirsalomon » 25 Oct 2017 12:13

Ich habe es dem Händler zurück geschickt, danke für Eure Hilfe, ich werde sicherlich noch einmal darauf zurück kommen :)

Ibi
Posts: 17
Joined: 19 Jun 2017 22:47

Re: Probleme mit RaZberry im Raspberry pi 3

Post by Ibi » 30 Oct 2017 22:47

Hallo!

Du musst (hättest gemusst - der Controller ist ja zurückgeschickt) Bluetooth abschalten - beim Pi Zero und Raspi3 blockieren die beiden Ports sich :-(

Gruß
Ibi

sirsalomon
Posts: 5
Joined: 18 Oct 2017 20:34

Re: Probleme mit RaZberry im Raspberry pi 3

Post by sirsalomon » 30 Oct 2017 22:51

Hatte ich, aber zudem, ich habe mir bereits ein neues Modul bestellt, dass kommt aber erst nach den Feiertagen.

Und dann alles auf Anfang und noch einmal versuchen :)

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests