Secure Danalock V3 inclusion fails

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
brun368
Posts: 8
Joined: 12 Sep 2015 01:49

Secure Danalock V3 inclusion fails

Post by brun368 » 02 Dec 2017 13:14

I tried to Include my Danalock V3 into my network, but the interview won't finish. Im using V2.3.6
The lock was right next to the Z-Way server while i tried to include.

In the Z-Way-server log i found these messages:

[2017-12-02 10:57:54.444] [D] [zway] SETDATA controller.data.statistics.backgroundRSSI.channel1 = 162 (0x000000a2)
[2017-12-02 10:57:54.444] [D] [zway] SETDATA controller.data.statistics.backgroundRSSI.channel2 = 165 (0x000000a5)
[2017-12-02 10:57:54.445] [D] [zway] SETDATA controller.data.statistics.backgroundRSSI.channel3 = 127 (0x0000007f)
[2017-12-02 10:57:54.445] [zway] Job 0x3b (Get background noise level): RSSI Ch#1: -91 dBm, Ch#2: -91 dBm, Ch#3: invalid
[2017-12-02 10:57:54.445] [D] [zway] Job 0x3b (Get background noise level): success
[2017-12-02 10:57:54.445] [zway] Removing job: Get background noise level
[2017-12-02 10:58:06.148] [W] [zway] Node 63:0 CC Security: secure channel not established by primary controller - skipping security
[2017-12-02 10:58:06.148] [D] [zway] SETDATA devices.63.instances.0.commandClasses.152.data.interviewCounter = 0 (0x00000000)
[2017-12-02 10:58:06.148] [zway] Saving configuration data to config/zddx/c9082010-DevicesData.xml
[2017-12-02 10:58:07.066] [zway] Interview step 2 skipped due to absence of Version CC
[2017-12-02 10:58:07.067] [D] [zway] SETDATA devices.63.data.SDK = "N/A"
[2017-12-02 10:58:07.124] [zway] Interview step 3 skipped due to absence of ManufacturerSpecific CC
[2017-12-02 10:58:07.124] [zway] Interview step 4 skipped due to absence of MultiInstance CC
[2017-12-02 10:58:07.125] [zway] Interview step 5
[2017-12-02 10:58:11.840] [D] [zway] RECEIVED: ( 01 0A 00 04 00 29 02 98 40 AE 00 AC )
[2017-12-02 10:58:11.841] [D] [zway] SENT ACK

what can i do to solve that problem?

fez
Posts: 76
Joined: 20 Jul 2015 23:03

Re: Secure Danalock V3 inclusion fails

Post by fez » 11 Dec 2017 12:18

Have you tried it with the Zway 3.0.0 supporting S2 security?
As far I've read the danalock supports both old and new z-wave security, but migth be something you could try.
Zway 3.0.0 is beta, so maybe save you current image before you upgrade, you might wanna switch back later.

I am interested in the Danalck, so if you have any updates would be great if you would share your experience.

User avatar
PoltoS
Posts: 4224
Joined: 26 Jan 2011 19:36

Re: Secure Danalock V3 inclusion fails

Post by PoltoS » 05 Jan 2018 08:22

Your log suggest that your Z-Way is not primary in your network. Set a field SecureInterviewAsSecondController in Defaults.xml to 1 (not sure exactly about the name)

User avatar
PoltoS
Posts: 4224
Joined: 26 Jan 2011 19:36

Re: Secure Danalock V3 inclusion fails

Post by PoltoS » 05 Jan 2018 08:23

And restart Z-Way.

Btw, city v2.3.6 it will be in S0 Security only.

For S2 you indeed need a v3.0.0 version

klaasjoerg
Posts: 124
Joined: 30 Sep 2016 23:49

Re: Secure Danalock V3 inclusion fails

Post by klaasjoerg » 07 Jan 2018 15:43

I have included two danalock V2 and one V3 without any problems and it's running also without any issues.
The only thing that was important to do was installing the latest firmware on the danalock, as the previous version had trouble and kept zwave-connection awake and thus emptying battery within less than a week. But this is fixed meanwhile....

brun368
Posts: 8
Joined: 12 Sep 2015 01:49

Re: Secure Danalock V3 inclusion fails

Post by brun368 » 07 Jan 2018 18:24

Thx for the answers so far.
I think my Z-Way is the primary device and I could not find the field you mentioned PoltoS.

here is my Defaults.xml:

Code: Select all

<?xml version="1.0"?>
<Defaults>
	<Autoconfig>1</Autoconfig><!-- Set to 1 to automatically configure devices or 0 to leave them as is -->
	<DeepInterview>1</DeepInterview><!-- Assume Interview done only after all Reports received from the CC -->
	<SaveDataAfterInterviewSteps>1</SaveDataAfterInterviewSteps><!-- Save data to xxxxxxxx-DeviceData.xml after each Interview steps. Set to 0 on slow devices to fast up interview -->
	<TryToBecomeSIS>1</TryToBecomeSIS><!-- Shall Z-Way try to become SIS -->
	<SecureInterviewAsInclusionController>1</SecureInterviewAsInclusionController><!-- If 1 - Z-Way will initiate interview as Inclusion Controller, if 0 - only as Primary/SIS -->
	<SecureInterviewAcceptedWithoutSchemeInherit>0</SecureInterviewAcceptedWithoutSchemeInherit><!-- If 1 - Z-Way will not fail secure inteview as secondary/inclusion controller if Scheme Inherit is not received, if 0 - fail interview as by Z-Wave protocol -->
	<SecureAllCCs>0</SecureAllCCs><!-- Always use Security if possible (even for CCs allowed as non-secure) -->
	<DeviceReplyTimeout>2</DeviceReplyTimeout><!-- Delay to wait (in seconds) for a device to reply with a REPORT on a GET command -->
	<DeviceRelaxDelay>3</DeviceRelaxDelay><!-- Delay between two subsequent packets sent to one device, measured in ticks (~10 ms). Some slow devices might need about 10 to respond correctly to burst of packets -->
	<SerialAPITimeout>0.0</SerialAPITimeout><!-- Extra time to be added to Serial API timouts. Set up to 1.0-3.0 sec in case of slow channel toward Z-Wave chip -->

	<CommandClass><!-- Default CC settings for devices -->
		<Wakeup>
			<WakeupInterval>3600</WakeupInterval><!-- Default Wakeup Interval to set during AutoConfiguration. Value 0 means to use default value from the device -->
			<KeepMeInformedInsteadOfSIS>1</KeepMeInformedInsteadOfSIS><!-- Set to 1 to assign Wakeup Notification to ourself or 0 to use SIS node instead as according to the protocol protocol -->
		</Wakeup>
		<SceneActuatorConf>
			<MaxScenes>16</MaxScenes><!-- Maximum number of scenes to use -->
		</SceneActuatorConf>
		<SceneControllerConf>
			<MaxScenes>16</MaxScenes><!-- Maximum number of scenes to use -->
		</SceneControllerConf>
		<Protection>
	 		<Mode>0</Mode><!-- Default Protection Mode to set during AutoConfiguration -->
	 	</Protection>
	 	<SensorMultilevel>
	 		<Fahrenheit>0</Fahrenheit><!-- Default scale to use -->
	 	</SensorMultilevel>
	 	<ThermostatSetPoint>
	 		<Fahrenheit>0</Fahrenheit><!-- Default scale to use -->
	 	</ThermostatSetPoint>
	 	<SwitchAll>
	 		<Mode>0</Mode><!-- Default SwichAll Mode to set during AutoConfiguration -->
		</SwitchAll>
		<MultiCmd>
			<MaxNum>3</MaxNum><!-- Maximum number of commands per MultiCmd -->
		</MultiCmd>
		<FirmwareUpdate>
			<FragmentSize>32</FragmentSize><!-- Fragment size on 3rd gen RaZberry and Z-Stick can not be more than 32 (max packet size was 37, with possible CRC it gives 32). On UZB and new 5gen it can be up to 40 bytes -->
		</FirmwareUpdate>
	</CommandClass>
	<Controller>
		<!-- Make sure to list more important first in case broken stick is used that support only 6 Command Classes -->
		<!-- Controllers own NIF -->
		<NodeInformationFrame>
			"ZWavePlusInfo"
			"Version"
			"MultiChannel"
			"MultiCmd"
			"Clock" <!-- for Danfoss must be in first 6 in case broken Sigma dongle is used -->
			"ClimateControlSchedule" <!-- for Danfoss must be in first 6 in case broken Sigma dongle is used -->
			"Security"
			"SwitchMultilevel"
			"SwitchBinary"
			"ManufacturerSpecific"
			"Time"
			"SceneActivation"
			"NodeNaming"
			"ApplicationStatus"
			"CentralScene"
			"CRC16"
			"PowerLevel"
			"Association"
			"AssociationGroupInformation"
			"MultiChannelAssociation"
			"DeviceResetLocally"
		</NodeInformationFrame>
		<!-- Controllers own NIF reported under Security -->
		<!-- CCs inside Secure NIF MUST be in ordinary NIF too -->
		<!-- Z-Way does not support Secure only CCs yet -->
		<SecureNodeInformationFrame>
			"MultiChannel"
			"Clock"
			"MultiCmd"
			"SwitchMultilevel"
			"SwitchBinary"
			"Time"
			"SceneActivation"
			"ApplicationStatus"
			"CentralScene"
			"Version"
			"ManufacturerSpecific"
		</SecureNodeInformationFrame>

		<CommandClassSupportedVersion>
			<Basic>1</Basic>
			<ApplicationStatus>1</ApplicationStatus>
			<SwitchBinary>1</SwitchBinary>
			<SwitchMultilevel>1</SwitchMultilevel>
			<ManufacturerSpecific>2</ManufacturerSpecific>
			<Clock>1</Clock>
			<MultiChannel>4</MultiChannel>
			<Version>2</Version>
			<MultiCmd>1</MultiCmd>
			<NodeNaming>1</NodeNaming>
			<Time>2</Time>
			<SceneActivation>1</SceneActivation>
			<ClimateControlSchedule>1</ClimateControlSchedule>
			<CentralScene>1</CentralScene>
			<ZWavePlusInfo>2</ZWavePlusInfo>
			<Security>1</Security>
			<CRC16>1</CRC16>
			<Association>2</Association>
			<AssociationGroupInformation>1</AssociationGroupInformation>
			<MultiChannelAssociation>3</MultiChannelAssociation>
			<PowerLevel>1</PowerLevel>
			<DeviceResetLocally>1</DeviceResetLocally>
		</CommandClassSupportedVersion>

		<Name>Gateway</Name><!-- Default Node Name of Controller -->
		<Location>Main Room</Location><!-- Default Node Location of Controller -->
		<AppVersion><!-- Version of Z-Way reported by Version CC -->
			<Major>2</Major>
			<Minor>3</Minor>
		</AppVersion>
		<HardwareVersion>1</HardwareVersion>
		<HostAppVersion><!-- Version of Host OS reported by Version CC -->
			<Major>1</Major>
			<Minor>0</Minor>
		</HostAppVersion>
		<ManufacturerSpecific><!-- Manufacturer info reported by ManufacturerSpcific CC -->
			<VendorID>277</VendorID>
			<ProductID>1</ProductID>
			<ProductTypeID>1</ProductTypeID>
		</ManufacturerSpecific>
		<SpecificDeviceClass>1</SpecificDeviceClass><!-- Controllers own Specific Device Class 1 = Static PC Controller -->
		<GenericDeviceClass>2</GenericDeviceClass><!-- Controllers own Generic Device Class 2 = Static Controller -->
		<Icons><!-- Icons for Z-Wave Plus Information CC -->
			<InstallerIcon>256</InstallerIcon>
			<UserIcon>256</UserIcon>
		</Icons>
		<Lifeline>
			<MaxNodes>3</MaxNodes>
		</Lifeline>
		<Channels>
			<Number>16</Number><!-- Number of Channels simulated for event handling -->
			<!-- Controllers instances capabilities -->
			<NodeInformationFrame>
				"SwitchBinary"
				"SwitchMultilevel"
				"SceneActivation"
				"CentralScene"
			</NodeInformationFrame>
			<GenericDeviceClass>17</GenericDeviceClass><!-- Generic Device Class of simulated Channel -->
			<SpecificDeviceClass>1</SpecificDeviceClass><!-- Specific Device Class of simulated Channel -->
			<Icons><!-- Icons for Z-Wave Plus Information CC -->
				<InstallerIcon>1536</InstallerIcon>
				<UserIcon>1536</UserIcon>
			</Icons>
		</Channels>
	</Controller>
</Defaults>
Any other idea, why the interview of the security class fails?

User avatar
PoltoS
Posts: 4224
Joined: 26 Jan 2011 19:36

Re: Secure Danalock V3 inclusion fails

Post by PoltoS » 11 Jan 2018 23:49

SecureInterviewAsInclusionController

brun368
Posts: 8
Joined: 12 Sep 2015 01:49

Re: Secure Danalock V3 inclusion fails

Post by brun368 » 28 Jan 2018 02:49

I set this var (SecureInterviewAsInclusionController) to 0 and it worked.
Thank you!

Post Reply