Unstable power from the Z-uno?

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
perjar
Posts: 13
Joined: 08 Apr 2018 18:02

Unstable power from the Z-uno?

Post by perjar » 18 May 2018 16:05

Hi,

Wanted to check with the community if you have encountered the same as I have: unstable output from the Z-uno when driven by USB power supply.

I am doing a small project similar to the example project "IR to Z-Wave":
https://z-uno.z-wave.me/examples/IR2ZWave/

My TSOP 7000 sensor prefers 5V so I attached mine to the 5V output instead of 3.3V, apart from that it was the same circuitry as in the example project.

I found that the IR sensor did not seem to be able to capture the IR signals from my remote control unless I pointed it straight at the sensor. This was not at all how other electronic equipment in the room reacted to the same remote control. Other devices responded to the remote no matter in which direction I was pointing it.

I was convinced there was a problem with my TSOP, too low sensitity or something.

As a last resort I tried the recommended design according to the TSOP data sheet, putting a capacitor between Vs and GND.
TSOP circuit.png
TSOP circuit.png (24.51 KiB) Viewed 37 times
And, suddenly, the IR sensor picks up the signals very well! No issues at all!

This was, I have to admit, a bit of a surprise, because the datasheet says that the capacitor is there to suppress disturbances from the power supply,

I can't be sure of course, but I think that the USB-chargers I amusing are good ones (they can't all be defective) and the Z-uno has no trouble running on its power. The question then is: is the Z-uno meddling with the 5V and 3.3V outputs and introduces disturbancies or what could be the issue you think?

Have anyone seen this too? If so, how have you dimesioned your capacitor? I am using 4.7 uF beacus it says so in the datasheet, but I have seen other sizes as well when browsing various projects in the web.

Thanks
Per

Post Reply