When can we expect release of 2.1.5?

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
User avatar
PoltoS
Posts: 4748
Joined: 26 Jan 2011 19:36

Re: When can we expect release of 2.1.5?

Post by PoltoS » 06 Apr 2019 17:33

We are running internal tests with 5 people testing it. A lot of small issues. Please be patient and let us finalize those fixed. We are also wishing to release is asap

Tillsy
Posts: 29
Joined: 15 Feb 2018 03:51

Re: When can we expect release of 2.1.5?

Post by Tillsy » 06 May 2019 14:58

Might have meant February 2020 :D :D :D

User avatar
PoltoS
Posts: 4748
Joined: 26 Jan 2011 19:36

Re: When can we expect release of 2.1.5?

Post by PoltoS » 07 May 2019 11:44

The beta is out. Documentation is in progress

rishamee
Posts: 20
Joined: 24 Aug 2018 18:56

Re: When can we expect release of 2.1.5?

Post by rishamee » 07 May 2019 20:44

Thx! 🤗

rishamee
Posts: 20
Joined: 24 Aug 2018 18:56

Re: When can we expect release of 2.1.5?

Post by rishamee » 10 May 2019 18:40

I installed the 2.1.5 Beta, and burned the boatloader. But unfortunately it does not work OK. Inclusion and exclusion worked, but when I press the service button and the RST-button, the red led blinks instead of the green led (normally my Z-Uno is in sleeping mode).

Tried to downgrade to 2.1.4, but that does not work. I get the message "Error 0 There is no firmware "zuno_bootloader_....*.bin" that is needed for your Z-Uno".

Tried 2.1.3, 2.1.1, but nothing works.

Please help!

K.R, rishamee

User avatar
PoltoS
Posts: 4748
Joined: 26 Jan 2011 19:36

Re: When can we expect release of 2.1.5?

Post by PoltoS » 11 May 2019 02:31

Have you uploaded your code on the 2.1.5? Try rescue mode and factory reset. Does it help?

rishamee
Posts: 20
Joined: 24 Aug 2018 18:56

Re: When can we expect release of 2.1.5?

Post by rishamee » 11 May 2019 09:48

What I did (I'll try to remember every step)

1. I solved the breaking changes. The only breaking changes which effected me were the changes in the config params. After that the sketch compiled well.
2. Because I upgraded from 2.1.3 to 2.1.5 beta, I first set the config params I use (64, 65, 72) to zero.
3. I uploaded the Bootloader
4. I excluded the Z-Uno from my network (I wanted to do that before uploading the Bootloader, but I forgot to do it)
5. I uploaded the sketch
From that point on the problems began... The red led blinks instead of the green led when I go into rescue mode.
6. I included the Z-Uno in the network (this still worked, although it took some time).

Maybe my issues are related to the config params. When the sketch starts, it detects if the sketch-version number is changed. I use config param 72 and a #define for it. If the value defined in the sketch is different from param 72, it saves the new version in the configuration (so I can check the sketch version with the Expert GUI after an OTA update).

I tried to set param 64 to the value 15 with the Expert GUI, but it responded with 83 (???)

I excluded the Z-Uno from the network, and tried to downgrade to 2.1.4. No success...
I tried to upload the sketch... no success (wrong Bootloader-version)
I tried a factory reset, no success...
I tried to upgrade my board-version in the Arduino IDE (1.8.5) to 2.1.5 again, but I can not find it anymore...

So I am stuck. I can't go forward, and I can't go back.

I know there is a risk when you install Beta-versions, especially when the documentation isn't publish yet. So the main purpose for my post is to let you check is there is a blocking issue in this Beta.

But if you can help me out of this, I'll be very pleased.

KR, rishamee

User avatar
PoltoS
Posts: 4748
Joined: 26 Jan 2011 19:36

Re: When can we expect release of 2.1.5?

Post by PoltoS » 11 May 2019 10:12

Please send me by mail remote access credentials and in Monday we look on it. Would that be possible?

rishamee
Posts: 20
Joined: 24 Aug 2018 18:56

Re: When can we expect release of 2.1.5?

Post by rishamee » 12 May 2019 09:19

Finally my Z-Uno operates normally (with 2.1.4).

I completely removed Z-Uno from the Arduino IDE, removed all directories from ~\AppData\Local\Arduino15\packages\Z-Uno\hardware\zw8051 and reinstalled 2.1.5 (with only the test-branch-url as boardsmanager.additional.url).

Tried to upload a minimal sketch. The IDE reported the upload was fine, but still the old sketch seemed to be active...

Downgraded to 2.1.4 (from the test-branch) and burned the bootloader. That worked!!

Compiled the minimal 2.1.4 sketch... Compilation failed (wrong path, it expected the main branch). Installed 2.1.4 in the IDE from the main branch and compiled and uploaded the sketch...

OK! Now the green led blinks :)

rishamee
Posts: 20
Joined: 24 Aug 2018 18:56

Re: When can we expect release of 2.1.5?

Post by rishamee » 12 May 2019 12:12

Did some additional tests
Started with the minimal sketch 2.1.4
Updated the IDE -> 2.1.5
Burned the bootloader, OK
Uploaded the minimal sketch into the 2.1.5 Z-Uno, OK (green led flashes)
Included the Z-Uno into my network, OK
Excluded again, still OK
Uploaded the original sketch (with all calls to zunoCFG commented out), it looked OK, but when I go into rescue mode, the red led flashes!

The main differences between the two scripts:

The minimal sketch is always awake, and has 2 sensor-multilevel channels. It uses analogue sensors
The original sketch is in sleeping mode, has the same mulitlevel-channels, it communicates with 2 digital sensors via I2C (and it uses INA219 and TSL2561 libraries).
The original sketch uses NZRAM.

So something in my original sketch causes the problems. Maybe ther is a breaking change that does not lead to compilation errors. I think I have to wait until the documentation is published.

Post Reply