Device dead after bootloader / fw upgrade

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
Atomic
Posts: 5
Joined: 28 Jun 2019 20:31

Device dead after bootloader / fw upgrade

Post by Atomic » 17 Oct 2019 19:40

I upgraded from 5.04 -> 5.07 -> 5.17 and now the device is marked dead in z-way 3.0.0

When upgrading to 5.07, I also upgraded the bootloader, which worked ok:

Code: Select all

ARGS:['./ZMESerialUpdater', 'serialapi_uzbupdate', '-d', '/dev/ttyAMA0', '-b', 'bootloader_Razberry_from_05_04_to_8aaa_2MB.bin', '-f', 'UPD_FIRMWARE_Razberry500_from_05_04_to_05_07.bin'] VERSION:LWE0.9 MD5:--NA--

...
>> ACK
Status: Waiting for Boot reflashing
Status: Waiting for Boot reflashing Started
Status: Waiting for Boot reflashing Finished
...
>> ACK
SILENT=False
FIRMWARE
Status: Openning port
>>  {HEX, len = 5}  01 03 00 07 FB
<< ACK
<  {HEX, len = 45}
 01 2B 01 07 05 04 01 47 04 00 00 02 FE 83 FF 88 CF 1F 00 00 FB 9F 7D A0 67 00 80 80 00 80 86 00
 00 00 E8 73 00 00 0E 00 00 40 1A 00 5E
>> ACK
Status: Writing NVM data Started
>>  {HEX, len = 138}
 01 88 00 2B 02 18 00 00 80 97 3E 16 1D 10 93 3A A8 15 88 EB 24 C0 68 89 14 06 C9 25 3C 6D 6F 61
...
<<  {HEX, len = 7}  01 05 01 2A 00 01 D0
>> ACK
Status: Reseting chip
>>  {HEX, len = 5}  01 03 00 08 F4
Status: Waiting for FW reflashing
Status: Waiting for FW reflashing Started
Status: Waiting for FW reflashing Finished
SILENT=True
...
<<  {HEX, len = 11}  01 09 00 0A 03 00 01 02 01 00 FD
>> ACK
SILENT=False
FULL INFO
Status: Openning port
>>  {HEX, len = 5}  01 03 00 07 FB
<< ACK
> ACK
SERIAL INFO
		 VERSION:  05 07  VENDOR:  01 47

ZME_CAPABILITIES
		     UID:  92 2E 19 9B A0 60 5A 43 A2 EA 12 E5 99 5E B2 D0
		  VENDOR:  00 00   NODES: FF
		   FLAGS:  05 00 00 00 00 00 00 00 00 00 00 00 00

FIRMWARE CRC
		    BOOT:  8A AA      FW:  BA 42
MISC
		    FREQ:  EU

				 NVR Content
--------------------------------------------------------------------------------------------
Prog/erase lock :  FF FF FF FF FF FF FF FF, Read back lock: FF
Rev 01, Cal 03, TXCal  19 14, SAW  0D 3C DE 05, Pin 01, CRC  92 E5
NMV: CS 04, TYPE 02, SIZE  01 00, PSIZE  01 00 (EEPROM M25PE20)
USB: VID  00 01, PID  00 02, UUID  00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
--------------------------------------------------------------------------------------------
FACTORY ID: WEEK 30, YEAR 16, CHIP  00 07, SER  0F 22, WS 5, HWREV: 00 01, CRC8 DF

elapsed 90.9553630352 seconds

So this seemed to work.
But the problem I think started on upgrade from 5.07 to 5.17:


Code: Select all

Programmer starting on Linux.
 ARGS:['./ZMESerialUpdater', 'serialapi_uzbupdate', '-d', '/dev/ttyAMA0', '-f', 'UPD_FIRMWARE_Razberry_from__05_07__to__05_17.bin'] VERSION:LWE0.9 MD5:--NA--
SILENT=True
>>  {HEX, len = 5}  01 03 00 07 FB
<< ACK
<<  {HEX, len = 45}
 01 2B 01 07 05 07 01 47 04 00 00 02 FE 83 FF 88 CF 1F 00 00 FB 9F 7D A0 67 00 80 80 00 80 86 00
 00 00 E8 73 00 00 0E 00 00 40 1A 00 5D
>> ACK
SILENT=False
FIRMWARE
Status: Openning port
>>  {HEX, len = 5}  01 03 00 07 FB
<< ACK
<<  {HEX, len = 45}
 01 2B 01 07 05 07 01 47 04 00 00 02 FE 83 FF 88 CF 1F 00 00 FB 9F 7D A0 67 00 80 80 00 80 86 00
 00 00 E8 73 00 00 0E 00 00 40 1A 00 5D
>> ACK
Status: Writing NVM data Started
...
<<  {HEX, len = 7}  01 05 01 2A 00 01 D0
>> ACK
Status: Reseting chip
>>  {HEX, len = 5}  01 03 00 08 F4
Status: Waiting for FW reflashing
Status: Waiting for FW reflashing Started
Status: Waiting for FW reflashing Finished
SILENT=True
>>  {HEX, len = 5}  01 03 00 07 FB
<<  {HEX, len = 12}  01 0A 00 0A 03 00 01 02 01 01 21 DE
>> ACK
SILENT=False
FULL INFO
Status: Openning port
>>  {HEX, len = 5}  01 03 00 07 FB
<< ACK
...

<<  {HEX, len = 6}  01 04 01 F2 00 08
>> ACK
SERIAL INFO
		 VERSION:  05 17  VENDOR:  01 47

ZME_CAPABILITIES
		     UID:  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
		  VENDOR:  00 00   NODES: 00
		   FLAGS:  00 00 00 00 00 00 00 00 00 00 00 00 00

FIRMWARE CRC
		    BOOT:  FF FF      FW:  FF FF
MISC
		    FREQ:  EU

				 NVR Content
--------------------------------------------------------------------------------------------
Prog/erase lock :  FF FF FF FF FF FF FF FF, Read back lock: FF
Rev FF, Cal FF, TXCal  FF FF, SAW  FF FF FF FF, Pin FF, CRC  FF FF
NMV: CS FF, TYPE FF, SIZE  FF FF, PSIZE  FF FF (EEPROM Unknown)
USB: VID  FF FF, PID  FF FF, UUID  FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
--------------------------------------------------------------------------------------------
FACTORY ID: WEEK 255, YEAR 255, CHIP  FF FF, SER  FF FF, WS 255, HWREV: FF FF, CRC8 FF

elapsed 89.2352759838 seconds

So all the data seemed to be removed from the device. Before the last step, the CRC was "BOOT: 8A AA FW: BA 42",
now it is all FF. Seems to be a problem.

Any idea how to fix this?

Atomic
Posts: 5
Joined: 28 Jun 2019 20:31

Re: Device dead after bootloader / fw upgrade

Post by Atomic » 17 Oct 2019 19:57

I powercycled my pi, and it seems the data is back:

Code: Select all

 ./ZMESerialUpdater serialapi_uzbupdate -d /dev/ttyAMA0


					Z-WAVE Serial API Tool
					     Version:LWE0.9
					     by Z-WAVE>ME


-->
Device ready in:3.05762982368 seconds
          FULL INFO
Openning port                            ..............................                            OK


          SERIAL INFO
		 VERSION:  05 17  VENDOR:  01 47

          ZME_CAPABILITIES
		     UID:  92 2E 19 9B A0 60 5A 43 A2 EA 12 E5 99 5E B2 D0
		  VENDOR:  00 00   NODES: FF
		   FLAGS:  05 00 00 00 00 00 00 00 00 00 00 00 00

          FIRMWARE CRC
		    BOOT:  8A AA      FW:  01 13
          MISC
		    FREQ:  EU

          				 NVR Content
          --------------------------------------------------------------------------------------------
          Prog/erase lock :  FF FF FF FF FF FF FF FF, Read back lock: FF
          Rev 01, Cal 03, TXCal  19 14, SAW  0D 3C DE 05, Pin 01, CRC  92 E5
          NMV: CS 04, TYPE 02, SIZE  01 00, PSIZE  01 00 (EEPROM M25PE20)
          USB: VID  00 01, PID  00 02, UUID  00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
          --------------------------------------------------------------------------------------------
          FACTORY ID: WEEK 30, YEAR 16, CHIP  00 07, SER  0F 22, WS 5, HWREV: 00 01, CRC8 DF

          elapsed 5.45704507828 seconds

But it is still marked dead in z-way-server 3.0.0

Atomic
Posts: 5
Joined: 28 Jun 2019 20:31

Re: Device dead after bootloader / fw upgrade

Post by Atomic » 17 Oct 2019 20:31

Now I went all the way up to 5.37, the leds are on for 2 seconds on restart, but z-way-server still sais device dead.

Code: Select all

./ZMESerialUpdater serialapi_uzbupdate -d /dev/ttyAMA0 -f UPD_FIRMWARE_Razberry_STATIC_2ch_ZME_05_20_04000002_ZME_05_24_04000002.bin


					Z-WAVE Serial API Tool
					     Version:LWE0.9
					     by Z-WAVE>ME


-->
Device ready in:3.06497097015 seconds
          FIRMWARE
Openning port                            ..............................                            OK
Writing NVM data                         ..............................                            OK
Setting update flag                      ..............................                            OK
Reseting chip                            ..............................                            OK
Waiting for FW reflashing                ..............................                            OK
-->
-->
-->
-->
Device ready in:12.3021781445 seconds
          FULL INFO
Openning port                            ..............................                            OK


          SERIAL INFO
		 VERSION:  05 24  VENDOR:  01 47

          ZME_CAPABILITIES
		     UID:  92 2E 19 9B A0 60 5A 43 A2 EA 12 E5 99 5E B2 D0
		  VENDOR:  00 00   NODES: FF
		   FLAGS:  05 00 00 00 00 00 00 00 00 00 00 00 00

          FIRMWARE CRC
		    BOOT:  8A AA      FW:  8B C3
          MISC
		    FREQ:  EU

          				 NVR Content
          --------------------------------------------------------------------------------------------
          Prog/erase lock :  FF FF FF FF FF FF FF FF, Read back lock: FF
          Rev 01, Cal 03, TXCal  19 14, SAW  0D 3C DE 05, Pin 01, CRC  92 E5
          NMV: CS 04, TYPE 02, SIZE  01 00, PSIZE  01 00 (EEPROM M25PE20)
          USB: VID  00 01, PID  00 02, UUID  00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
          --------------------------------------------------------------------------------------------
          FACTORY ID: WEEK 30, YEAR 16, CHIP  00 07, SER  0F 22, WS 5, HWREV: 00 01, CRC8 DF

          elapsed 93.6052629948 seconds

User avatar
PoltoS
Posts: 5056
Joined: 26 Jan 2011 19:36

Re: Device dead after bootloader / fw upgrade

Post by PoltoS » 17 Oct 2019 22:08

Please show the Z-Way log

iosman000
Posts: 1
Joined: 09 Nov 2019 08:10

Re: Device dead after bootloader / fw upgrade

Post by iosman000 » 09 Nov 2019 08:12

Atomic wrote:
17 Oct 2019 20:31
Now I went all the way up to 5.37, the leds are on for 2 seconds on restart, but z-way-server still sais device dead.

Code: Select all

./ZMESerialUpdater serialapi_uzbupdate -d /dev/ttyAMA0 -f UPD_FIRMWARE_Razberry_STATIC_2ch_ZME_05_20_04000002_ZME_05_24_04000002.bin


					Z-WAVE Serial API Tool
					     Version:LWE0.9
					     by Z-WAVE>ME


-->
Device ready in:3.06497097015 seconds
          FIRMWARE
Openning port                            ..............................                            OK
Writing NVM data                         ..............................                            OK
Setting update flag                      ..............................                            OK
Reseting chip                            ..............................                            OK
Waiting for FW reflashing                ..............................                            OK
-->
-->
-->
-->
Device ready in:12.3021781445 seconds
          FULL INFO
Openning port                            ..............................                            OK


          SERIAL INFO
		 VERSION:  05 24  VENDOR:  01 47

          ZME_CAPABILITIES
		     UID:  92 2E 19 9B A0 60 5A 43 A2 EA 12 E5 99 5E B2 D0
		  VENDOR:  00 00   NODES: FF
		   FLAGS:  05 00 00 00 00 00 00 00 00 00 00 00 00

          FIRMWARE CRC
		    BOOT:  8A AA      FW:  8B C3
          MISC
		    FREQ:  EU

          				 NVR Content
          --------------------------------------------------------------------------------------------
          Prog/erase lock :  FF FF FF FF FF FF FF FF, Read back lock: FF
          Rev 01, Cal 03, TXCal https://tweakboxx-app.com 19 14, SAW  0D 3C DE 05, Pin 01, CRC  92 E5
          NMV: CS 04, TYPE 02, SIZE  01 00, https://tweakbox-app.net PSIZE  01 00 (EEPROM M25PE20)
          USB: VID  00 01, PID https://tweakboxx.net  00 02, UUID  00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
          --------------------------------------------------------------------------------------------
          FACTORY ID: WEEK 30, YEAR 16, CHIP  00 07, SER  0F 22, WS 5, HWREV: 00 01, CRC8 DF

          elapsed 93.6052629948 seconds
thanks for the solution.

Post Reply